通达信筹码三个买点主图指标 源码 贴图

2022-12-20 10:25:00来源:本站整理浏览:1713

通达信筹码三个买点主图指标 源码 贴图

通达信筹码三个买点主图指标 源码 贴图

通达信筹码三个买点主图指标 源码 贴图


{所属行业及板块}
DRAWTEXT_FIX(1,0.01,0.01,0,'地区板块:')COLORWHITE;
DRAWTEXT_FIX(1,0.10,0.01,0,DYBLOCK)COLORCYAN;{数值}
DRAWTEXT_FIX(1,0.18,0.01,0,'所属行业:')COLORWHITE;
DRAWTEXT_FIX(1,0.25,0.01,0, HYBLOCK)COLORCYAN;{数值}
市盈率:=DYNAINFO(39);
DRAWTEXT_FIX(1,0.30,0.01,0,'市盈率:'),COLORWHITE;
DRAWNUMBER_FIX(1,0.40,0.01,1,市盈率),COLORCYAN;
净利润率:=CONST(FINANCE(30)/FINANCE(20));
DRAWTEXT_FIX(1,0.42,0.01,0,'净利润率:'),COLORWHITE;
DRAWNUMBER_FIX(1,0.50,0.01,0,净利润率),COLORCYAN;
净利润同比%:=FINANCE(43);{净利润同比增长率}
DRAWTEXT_FIX(1,0.54,0.01,0,'净利润同比%:'),COLORWHITE;
DRAWNUMBER_FIX(1,0.65,0.01,0,净利润同比%),COLORCYAN;
DRAWTEXT_FIX(1,0.72,0.01,0,'概念板块:')COLORWHITE;
DRAWTEXT_FIX(1,0.81,0.01,0,GNBLOCK)COLORCYAN;{数值}
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;{涨停};
HH:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210;
离合:(EMA(HH,5)-((H-EMA(HH,5))*H-EMA(HH,5))/EMA(HH,5)),COLORGREEN,LINETHICK2;
上升离合4:(EMA(HH,90)+((H-EMA(HH,90))*H-EMA(HH,90))/EMA(HH,90)),COLORRED,LINETHICK2;
TP1:=CROSS(MAX((EMA(HH,250)-((H-EMA(HH,250))*H-EMA(HH,250))/EMA(HH,250)),MAX((EMA(HH,120)-((H-EMA(HH,120))*H-EMA(HH,120))/EMA(HH,120)),MAX((EMA(HH,90)-((H-EMA(HH,90))*H-EMA(HH,90))/EMA(HH,90)),MAX((EMA(HH,60)-((H-EMA(HH,60))*H-EMA(HH,60))/EMA(HH,60)),MAX((EMA(HH,30)-((H-EMA(HH,30))*H-EMA(HH,30))/EMA(HH,30)),MAX((EMA(HH,10)-((H-EMA(HH,10))*H-EMA(HH,10))/EMA(HH,10)),离合)))))),EMA(HH,5));
TP3:=CROSS(C,MAX((EMA(HH,250)-((H-EMA(HH,250))*H-EMA(HH,250))/EMA(HH,250)),MAX((EMA(HH,120)-((H-EMA(HH,120))*H-EMA(HH,120))/EMA(HH,120)),MAX((EMA(HH,90)-((H-EMA(HH,90))*H-EMA(HH,90))/EMA(HH,90)),MAX((EMA(HH,60)-((H-EMA(HH,60))*H-EMA(HH,60))/EMA(HH,60)),MAX((EMA(HH,30)-((H-EMA(HH,30))*H-EMA(HH,30))/EMA(HH,30)),MAX((EMA(HH,10)-((H-EMA(HH,10))*H-EMA(HH,10))/EMA(HH,10)),离合)))))));
TP6:=CROSS((EMA(HH,90)+((H-EMA(HH,90))*H-EMA(HH,90))/EMA(HH,90)),EMA(C,5));
DRAWTEXT(TP1 AND ZT,L,'?金元宝'),COLORRED,LINETHICK4;
DRAWTEXT(TP3 AND ZT,L,'?精准导弹'),COLORWHITE,LINETHICK4;
DRAWTEXT(TP6 AND ZT,L,'?超级主升'),COLORYELLOW,LINETHICK4;
DRAWTEXT(TP3,L,'买'),COLORGREEN,LINETHICK4;
DRAWKLINE(H,O,L,C);
黄金线:(EMA(C,15)),POINTDOT,LINETHICK4,COLORYELLOW;
{老鼠仓}{股票下载网WWW.GPXIAZAI.COM}
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,LOW*0.96,'老鼠仓'),COLOR4080FF;
{金山谷}
山谷:=MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,30) AND CROSS(MA(C,10),MA(C,30));
DRAWTEXT(山谷 AND MA(C,30)>MA(C,120),MA(C,30)-0.08,'金山谷'),COLORYELLOW;
{黑马起飞点}
实在1:=MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20)
AND O<MA(C,10) AND C>MA(C,5)
AND C<30
AND V<MA(V,60);
DRAWTEXT(实在1,MA(C,20)*0.95,'一阳穿双'),COLORCYAN;
DRAWTEXT(实在1,MA(C,20)*0.9,'无量黑马止跌'),COLORCYAN;
STICKLINE(实在1,MA(C,20)*0.9,MA(C,20)*0.95,0.01,0),COLORCYAN;
实在2:=MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20)
AND O<MA(C,10) AND C>MA(C,5)
AND C<30
AND V>MA(V,60)
AND COUNT(V>MA(V,60),2)=1;
DRAWTEXT(实在2,MA(C,20)*0.95,'一阳穿双'),COLORWHITE;
DRAWTEXT(实在2,MA(C,20)*0.9,'有量黑马起飞'),COLORWHITE;
STICKLINE(实在2,MA(C,20)*0.9,MA(C,20)*0.95,0.01,0),COLORWHITE;

 

股票公式栏目导航

本类热门

相关公式