K线图叠加筹码分布 通达信主图指标 源码 贴图

2020-07-10 09:45:00来源:本站整理浏览:641

K线图叠加筹码分布 通达信主图指标 源码 贴图

K线图叠加筹码分布 通达信主图指标 源码 贴图


DRAWTEXT_FIX(1,0.00,0.00,0,'主题投资:')COLOR0000FF;
DRAWTEXT_FIX(1,0.07,0.00,0,EXTERNSTR(0,1))COLOR0000FF;
DRAWTEXT_FIX(1,0.00,0.08,0,'主营业务:'),COLORMAGENTA;
DRAWTEXT_FIX(1,0.07,0.08,0,EXTERNSTR(0,2)),COLORMAGENTA;
DRAWTEXT_FIX(C>0,0.00,0.16,0,STRCAT('所属概念:',GNBLOCK)),COLORYELLOW;
DRAWTEXT_FIX(C>0,0.00,0.24,0,STRCAT('所属行业:',HYBLOCK)),COLORYELLOW;


MA1:EMA(CLOSE,5);
MA2:EMA(CLOSE,10);
MA3:EMA(CLOSE,30);
MA4:EMA(CLOSE,60);
MA5:EMA(CLOSE,120);
MA6:EMA(CLOSE,250);

{成本分布}

HB:=COST(99.9);
LB:=COST(0.1);
B3:=(HB-LB)/50;
B31:=HB-B3;
B32:=HB-2*B3;
B33:=HB-3*B3;
B34:=HB-4*B3;
B35:=HB-5*B3;
B36:=HB-6*B3;
B37:=HB-7*B3;
B38:=HB-8*B3;
B39:=HB-9*B3;
B310:=HB-10*B3;
B311:=HB-11*B3;
B312:=HB-12*B3;
B313:=HB-13*B3;
B314:=HB-14*B3;
B315:=HB-15*B3;
B316:=HB-16*B3;
B317:=HB-17*B3;
B318:=HB-18*B3;
B319:=HB-19*B3;
B320:=HB-20*B3;
B321:=HB-21*B3;
B322:=HB-22*B3;
B323:=HB-23*B3;
B324:=HB-24*B3;
B325:=HB-25*B3;
B326:=HB-26*B3;
B327:=HB-27*B3;
B328:=HB-28*B3;
B329:=HB-29*B3;
B330:=HB-30*B3;
B331:=HB-31*B3;
B332:=HB-32*B3;
B333:=HB-33*B3;
B334:=HB-34*B3;
B335:=HB-35*B3;
B336:=HB-36*B3;
B337:=HB-37*B3;
B338:=HB-38*B3;
B339:=HB-39*B3;
B340:=HB-40*B3;
B341:=HB-41*B3;
B342:=HB-42*B3;
B343:=HB-43*B3;
B344:=HB-44*B3;
B345:=HB-45*B3;
B346:=HB-46*B3;
B347:=HB-47*B3;
B348:=HB-48*B3;
B349:=HB-49*B3;
A1:=WINNER(HB)*100-WINNER(B31)*100;
A2:=WINNER(B31)*100-WINNER(B32)*100;
A3:=WINNER(B32)*100-WINNER(B33)*100;
A4:=WINNER(B33)*100-WINNER(B34)*100;
A5:=WINNER(B34)*100-WINNER(B35)*100;
A6:=WINNER(B35)*100-WINNER(B36)*100;
A7:=WINNER(B36)*100-WINNER(B37)*100;
A8:=WINNER(B37)*100-WINNER(B38)*100;
A9:=WINNER(B38)*100-WINNER(B39)*100;
A10:=WINNER(B39)*100-WINNER(B310)*100;
A11:=WINNER(B310)*100-WINNER(B311)*100;
A12:=WINNER(B311)*100-WINNER(B312)*100;
A13:=WINNER(B312)*100-WINNER(B313)*100;
A14:=WINNER(B313)*100-WINNER(B314)*100;
A15:=WINNER(B314)*100-WINNER(B315)*100;
A16:=WINNER(B315)*100-WINNER(B316)*100;
A17:=WINNER(B316)*100-WINNER(B317)*100;
A18:=WINNER(B317)*100-WINNER(B318)*100;
A19:=WINNER(B318)*100-WINNER(B319)*100;
A20:=WINNER(B319)*100-WINNER(B320)*100;
A21:=WINNER(B320)*100-WINNER(B321)*100;
A22:=WINNER(B321)*100-WINNER(B322)*100;
A23:=WINNER(B322)*100-WINNER(B323)*100;
A24:=WINNER(B323)*100-WINNER(B324)*100;
A25:=WINNER(B324)*100-WINNER(B325)*100;
A26:=WINNER(B325)*100-WINNER(B326)*100;
A27:=WINNER(B326)*100-WINNER(B327)*100;
A28:=WINNER(B327)*100-WINNER(B328)*100;
A29:=WINNER(B328)*100-WINNER(B329)*100;
A30:=WINNER(B329)*100-WINNER(B330)*100;
A31:=WINNER(B330)*100-WINNER(B331)*100;
A32:=WINNER(B331)*100-WINNER(B332)*100;
A33:=WINNER(B332)*100-WINNER(B333)*100;
A34:=WINNER(B333)*100-WINNER(B334)*100;
A35:=WINNER(B334)*100-WINNER(B335)*100;
A36:=WINNER(B335)*100-WINNER(B336)*100;
A37:=WINNER(B336)*100-WINNER(B337)*100;
A38:=WINNER(B337)*100-WINNER(B338)*100;
A39:=WINNER(B338)*100-WINNER(B339)*100;
A40:=WINNER(B339)*100-WINNER(B340)*100;
A41:=WINNER(B340)*100-WINNER(B341)*100;
A42:=WINNER(B341)*100-WINNER(B342)*100;
A43:=WINNER(B342)*100-WINNER(B343)*100;
A44:=WINNER(B343)*100-WINNER(B344)*100;
A45:=WINNER(B344)*100-WINNER(B345)*100;
A46:=WINNER(B345)*100-WINNER(B346)*100;
A47:=WINNER(B346)*100-WINNER(B347)*100;
A48:=WINNER(B347)*100-WINNER(B348)*100;
A49:=WINNER(B348)*100-WINNER(B349)*100;
A50:=WINNER(B349)*100-WINNER(LB)*100;
STICKLINE(ISLASTBAR,HB ,HB ,A1*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B31 ,B31 ,A1*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B32 ,B32 ,A2*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B33 ,B33 ,A3*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B34 ,B34 ,A4*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B35 ,B35 ,A5*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B36 ,B36 ,A6*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B37 ,B37 ,A7*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B38 ,B38 ,A8*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B39 ,B39 ,A9*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B310 ,B310 ,A10*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B311 ,B311 ,A11*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B312 ,B312 ,A12*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B313 ,B313 ,A13*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B314 ,B314 ,A14*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B315 ,B315 ,A15*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B316 ,B316 ,A16*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B317 ,B317 ,A17*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B318 ,B318 ,A18*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B319 ,B319 ,A19*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B320 ,B320 ,A20*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B321 ,B321 ,A21*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B322 ,B322 ,A22*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B323 ,B323 ,A23*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B324 ,B324 ,A24*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B325 ,B325 ,A25*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B326 ,B326 ,A26*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B327 ,B327 ,A27*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B328 ,B328 ,A28*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B329 ,B329 ,A29*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B330 ,B330 ,A30*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B331 ,B331 ,A31*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B332 ,B332 ,A32*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B333 ,B333 ,A33*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B334 ,B334 ,A34*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B335 ,B335 ,A35*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B336 ,B336 ,A36*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B337 ,B337 ,A37*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B338 ,B338 ,A38*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B339 ,B339 ,A39*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B340 ,B340 ,A40*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B341 ,B341 ,A41*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B342 ,B342 ,A42*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B343 ,B343 ,A43*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B344 ,B344 ,A44*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B345 ,B345 ,A45*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B346 ,B346 ,A46*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B347 ,B347 ,A47*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,B348 ,B348 ,A48*50 ,0 ),COLORGRAY;
STICKLINE(ISLASTBAR,LB ,LB ,A50*50 ,0 ),COLORGRAY;


VAR1:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VAR2:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
{WWW.GPXIAZAI.COM}
VAR4:=LLV(LOW,34);
VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);
VAR6:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR7:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR8:=VAR6<REF(VAR7,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
STICKLINE(VAR8 AND COUNT(VAR8,18)=1,0,18,8,0),COLORAA00BB;{粉色住}
STICKLINE(VAR8 AND COUNT(VAR8,18)=1,0,18,8,0),COLORBB11BB;
STICKLINE(VAR8 AND COUNT(VAR8,18)=1,0,18,5,0),COLORCC22BB;
STICKLINE(VAR8 AND COUNT(VAR8,18)=1,0,18,3,0),COLORDD33BB;
STICKLINE(VAR8 AND COUNT(VAR8,18)=1,0,18,1,0),COLOREE44BB;
DRAWTEXT(VAR8 AND COUNT(VAR8,18)=1,16,'●↙大资金进场'),COLOR0099FF;
DRAWTEXT(VAR8 AND COUNT(VAR8,18)=1,12,'●↙择机买入'),COLOR0033FF;
DRAWTEXT(VAR8 AND COUNT(VAR8,18)=1,8,'●↙多数会涨'),COLORFFFFAA;


JJJ:=IF(DYNAINFO(8)>0.01,0.01*DYNAINFO(10)/DYNAINFO(8),DYNAINFO(3));
DDD1:=(DYNAINFO(5)<0.01 || DYNAINFO(6)<0.01);
JJJT:=IF(DDD1,1,(JJJ<(DYNAINFO(5)+0.01) && JJJ>(DYNAINFO(6)-0.01)));
多空1:=IF(JJJT,DMA(AMOUNT/(100*VOL),100*VOL/FINANCE(7)),EMA((HIGH+LOW+CLOSE)/3,120));
指:=IF(C>400,多空1,DRAWNULL),,LINETHICK3,COLORGREEN;
多空:IF(C<400,DMA(C,(VOL/CAPITAL)),指),LINETHICK2,COLORFF00FF;
IF(多空<REF(多空,1),多空,DRAWNULL),LINETHICK2,COLORGREEN;
DRAWNUMBER(ISLASTBAR AND C>=多空,多空,多空),COLORFF00FF;
DRAWNUMBER(ISLASTBAR AND C<多空,多空,多空),COLORGREEN;

 

股票公式栏目导航

本类热门

相关公式