通达信分时突破主图指标 红线买入 绿线卖出 黄线关注 紫线追涨 源码 贴图

2021-10-18 10:01:00来源:本站整理浏览:5460

超强分时,有收益统计
红线买入 绿线卖出 黄线关注 紫线追涨
所有的收益统计都是第一次的信号直到现价

通达信分时突破主图指标 红线买入 绿线卖出 黄线关注 紫线追涨 源码 贴图

通达信分时突破主图指标 红线买入 绿线卖出 黄线关注 紫线追涨 源码 贴图


{突破信号}
XG1:HHV(H,480),DOTLINE,COLORRED;
STICKLINE(FILTER(CROSS(C,REF(XG1,1)),10) AND C>REF(XG1,1),C*0.99,C,8,0),COLORGREEN;
DRAWTEXT(FILTER(CROSS(C,REF(XG1,1)),10) AND C>REF(XG1,1),C*0.99,'突'),COLOR0080FF;

{分时突破}
{MACD}
现价:C,COLORWHITE,LINETHICK2;
均价11:SUM(C*V,240)/SUM(V,240),COLORRED,LINETHICK2;
TT:=BARSCOUNT(C);
前高:=REF(HHV(H,TT),1);
突破:=CROSS(C,REF(HHV(H,TT),1)){ AND HHVBARS(VOL,TT)=0} AND C/均价11<1.09 AND TT>1 AND TT<240;
主力扫盘:=COUNT(突破,13)>=3 AND CROSS(C,REF(HHV(H,TT),1)){ AND HHVBARS(VOL,TT)=0};
DRAWTEXT(主力扫盘,前高, '←'),COLORYELLOW;
已主力扫盘:=BARSLAST(主力扫盘)<13;
全仓买进:=CROSS(C,REF(HHV(H,TT),1)) AND HHVBARS(VOL,TT)=0 AND C/均价11<1.09 AND TT>1 AND TT<240 AND BARSLAST(主力扫盘)>=20;
DRAWTEXT(全仓买进 ,前高, '←全仓'),COLORCYAN;
HJ_2:=DYNAINFO(4)>0 AND HHV(HIGH,2)/LLV(LOW,2)<1.25 AND REF(CLOSE,1)<LLV(LOW,3)+(HHV(HIGH,3)-LLV(LOW,3))*0.85;
HJ_9:=EMA(CLOSE,2);
HJ_10:=EMA(CLOSE,3);
HJ_11:=MAX(HJ_9,HJ_10);
X2:=CLOSE>HJ_11 AND HJ_2 AND (CLOSE>REF(HHV(HIGH,2),1) AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.015) AND (V/CAPITAL<=0.2) AND C/REF(C,1)<1.07;
{牛熊线}
NX:=MA(((SLOPE(C,20)*5)+C),10);
{中枢}
B1:=HOUR=09 AND MINUTE=45;
B20:=LLV(L,15);
B30:=BARSLAST(B1);
B4:=REF(B20,B30);
B5:CONST(B4),COLORFF80FF,CIRCLEDOT,LINETHICK2;

C1:=HOUR=09 AND MINUTE=45;
C2:=HHV(H,15);
C3:=BARSLAST(C1);
C4:=REF(C2,C3);
C5:CONST(C4),COLORFF80FF,CIRCLEDOT,LINETHICK2;

{DRAWBAND(C5,RGB(204,204,204),B5,RGB(204,204,204));}
{MACD}
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD10:=(DIF-DEA)*2;
AA0:=MACD10>00 AND DIF>0 AND DEA>0;
{捉牛信号}
A100:=HOUR=10 AND MINUTE=0;
A20:=HHV(H,30);
A30:=BARSLAST(A100);
A40:=REF(A20,A30);
A50:=CONST(A40);
A80:=CLOSE>A50 AND REF(C<=A50,1) AND CLOSE>NX;
AB:=FILTER(A80,100);
A90:=DYNAINFO(3);
AC:=CLOSE<=A90*1.04 AND CLOSE>A90;
量比:=V/REF(MA(V,5),1);
XG:=AA0 AND AB AND AC AND A40>A90 AND 量比>=1;
DRAWICON(XG,A50,23);
DRAWTEXT(FILTER(CROSS(C,REF(XG,1)),10) AND C>REF(XG,1),C*0.995,'突'),COLORYELLOW;
HJ_4:=CLOSE;
HJ_5:=(CLOSE-REF(CLOSE,5))/REF(CLOSE,5);
BAB1:=STICKLINE(HJ_5>0,DYNAINFO(3),DYNAINFO(3)*(1+HJ_5),0.1,0);
BAB2:=STICKLINE(HJ_5<0,DYNAINFO(3),DYNAINFO(3)*(1+HJ_5),0.1,0);
HJ_6:=CLOSE/DYNAINFO(3);
HJ_7:=FILTER(HJ_5>0.015 AND HJ_5>REF(HJ_5,1)*2 AND VOL>REF(VOL,1)*2 AND CLOSE>REF(CLOSE,1) OR HJ_5>0.025,240);
DRAWICON(HJ_7 AND HJ_6<1.06 AND CLOSE>DYNAINFO(3),C,23);{东风小图标}
DRAWICON(HJ_7 AND HJ_6<1.06 AND CLOSE>DYNAINFO(3),C,1);
DRAWTEXT(HJ_7 AND HJ_6<1.06 AND CLOSE>DYNAINFO(3),C,' 启动')COLORGREEN;
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:L1+P1*8/9,COLORLIRED,DOTLINE;
支撑:L1+P1*0.5/9,COLORGREEN,DOTLINE;
DRAWTEXT(LONGCROSS(支撑,C,2),C-0.01,' 买入'),COLOR0000FF;
WA1:=V*C/100;
WA2:=SUM((IF(((WA1/8>20) AND (CLOSE>(REF(CLOSE,1)))),WA1,0)),0);
WA3:=SUM((IF(((WA1/8>20) AND (CLOSE<(REF(CLOSE,1)))),WA1,0)),0);
WA4:=SUM((IF(((WA1/8<20) AND (CLOSE>(REF(CLOSE,1)))),WA1,0)),0);
WA5:=SUM((IF(((WA1/8<20) AND (CLOSE<(REF(CLOSE,1)))),WA1,0)),0);
机构买盘:=(WA2);
机构卖盘:=(WA3);
散户买盘:=(WA4);
散户卖盘:=(WA5);
DRAWTEXT_FIX(1,0.000,0.083,0,STRCAT(STRCAT('【机买】',CON2STR(机构买盘,2)),' 万')),COLORRED;
DRAWTEXT_FIX(1,0.852,0.083,0,STRCAT(STRCAT('【机卖】',CON2STR(机构卖盘,2)),' 万')),COLORGREEN;

X_1:=HIGH-REF(HIGH,1);
X_2:=REF(LOW,1)-LOW;
X_3:=EMA(IF(X_1>0 AND X_1>X_2,X_1,0),28);
X_4:=EMA(IF(X_2>0 AND X_2>X_1,X_2,0),28);
X_5:=EMA(X_3/TR,28);
X_6:=EMA(X_4/TR,28);
X_7:=EMA((CLOSE+HIGH+LOW)/3,2);
X_8:=MAX(DYNAINFO(3),EMA(DYNAINFO(5),5));
X_9:=MIN(DYNAINFO(3),EMA(DYNAINFO(6),5));
X_10:=(COST(95)+DYNAINFO(11))/2;
X_11:=(COST(5)+DYNAINFO(11))/2;
X_12:=CONST((X_8+X_10)/2);
X_13:=CONST((X_9+X_11)/2);
X_14:=(X_12+X_13)/2;
X_15:=X_13+X_14-X_12;
X_16:=(X_13+X_15)/2;
X_17:=(X_15+X_16)/2;
X_18:=(EMA(CLOSE,24)-EMA(CLOSE,52))*4+X_14;
X_19:=EMA(X_18,18);
MCD:=(X_18-X_19)*2+X_14,NODRAW,COLORYELLOW;
X_20:=3*SMA((CLOSE-LLV(LOW,54))/(HHV(HIGH,54)-LLV(LOW,54)),3,1)-2*SMA(SMA((CLOSE-LLV(LOW,54))/(HHV(HIGH,54)-LLV(LOW,54)),3,1),3,1);
X_21:=MEMA(X_20,10);
X_22:=EMA(X_21,10);
X_23:=IF(EXIST(CROSS(X_12,X_7),5) AND EXIST(CLOSE>X_12,10) AND X_21<HHV(X_21,10) AND X_22<REF(X_22,1),1,0);
X_24:=IF(EXIST(CROSS(X_7,X_13),5) AND EXIST(CLOSE<X_13,10) AND X_21>LLV(X_21,10) AND X_22>REF(X_22,1),1,0);
卖出:=X_23=1 AND REF(X_23,1)=0;


DRAWICON(X_23=1 AND REF(X_23,1)=0,X_12,8);
DRAWICON(X_24=1 AND REF(X_24,1)=0,X_13,7);

STICKLINE(X_23=1 AND REF(X_23,1)=0,X_12,X_13,0,0),COLORGREEN;

STICKLINE(X_24=1 AND REF(X_24,1)=0,X_12,X_13,0,0),COLORRED;

PA2:=BARSSINCE(卖出)+1;
首次卖出价:=REF(C,PA2-1),NODRAW;
卖出收益:(DYNAINFO(7)-首次卖出价)/首次卖出价*100,NODRAW,COLORGREEN;
DRAWTEXT_FIX(1,0.0,1-0.0,0,STRCAT(STRCAT('【卖出收益】',CON2STR(卖出收益,2)),'%')),COLORGREEN;
买入:=X_24=1 AND REF(X_24,1)=0;
PA1:=BARSSINCE(买入)+1;
首次买入价:=REF(C,PA1-1),NODRAW;
买入收益:(DYNAINFO(7)-首次买入价)/首次买入价*100,NODRAW,COLORRED;
DRAWTEXT_FIX(1,0.0,1-0.098,0,STRCAT(STRCAT('【买入收益】',CON2STR(买入收益,2)),'%')),COLORRED;
买卖收益:(首次卖出价-首次买入价)/首次买入价*100,NODRAW,COLORRED;

虎:= (EXPMA(CLOSE,500)-REF(EXPMA(CLOSE,500),1))/REF(EXPMA(CLOSE,500),1)*100;

DRAWICON(CROSS(EXPMA(虎,120)-0.0004,EXPMA(虎,200)),均价11,13);
Q:=BETWEEN(C/(SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C))),1.05,0.95);

Q2:=IF(Q=0,MA(C,BARSCOUNT(C)),(SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C))));

DRAWICON(CROSS((C/Q2),1.03),均价11,5);

YD:=DYNAINFO(3);
MM:=IF(C=DYNAINFO(4)*1.1 AND L=DYNAINFO(4)*1.1,H-YD,H-REF(C,1));
M:=IF(MM>0,MM,0.0);
SS:=IF(C=DYNAINFO(4)*0.9 AND H=DYNAINFO(4)*0.9,YD-H,REF(C,1)-L);
S:=IF(SS>0,SS,0.0);
HJ:=M+S;
买入力度:=M/HJ*AMOUNT/CAPITAL;
卖出力度:=S/HJ*AMOUNT/CAPITAL;


{分时买卖追涨}
N:=7.5;
MMA30:=EMA(CLOSE,30);
强弱界定:=IF(PERIOD=0,EMA(CLOSE,900),DRAWNULL),COLORWHITE,LINETHICK2;
分时价量线:=SUM(C*V,240)/SUM(V,240),COLORYELLOW,LINETHICK1;
实时涨幅限制:=(C/DYNAINFO(3)-1)*100;
{买卖力度}

买卖力度:=SUM((买入力度-卖出力度),0),COLORAAAA00,NODRAW;
买卖力度比:=买卖力度/SUM((买入力度+卖出力度),0)*50,NODRAW,COLORFFFFFF,LINETHICK2;
买卖力度比设置:=买卖力度比+50;
买卖力度比限制:=IF(买卖力度比设置>80,80,IF(买卖力度比设置<20,20,买卖力度比设置));
分时力度线:=SUM(C*买卖力度比限制,240)/SUM(买卖力度比限制,240);
买卖力度参考线0:=MA(买卖力度比限制,8)*1.062;
买卖力度参考线:=MA(买卖力度比限制,8)*1.091;
买卖力度参考线2:=MA(买卖力度比限制,5)*1.191;
平安分时关注:=买卖力度参考线<50 AND CROSS(买卖力度比限制,50);
平安分时追涨:=(CROSS(买卖力度比限制,买卖力度参考线) OR (CROSS(买卖力度比限制,买卖力度参考线0) AND 买卖力度比限制>70))
AND (买卖力度比限制>50) AND (MMA30>强弱界定 OR 分时价量线>强弱界定 OR C>MAX(MMA30,强弱界定)) AND C>分时价量线 {www.gpxiazai.com}
AND V>MA(V,20) AND DYNAINFO(17)>=1.2 AND 实时涨幅限制<N;
DRAWTEXT(FILTER(平安分时关注,20),现价,'←关注'),COLOR00FFFF;
STICKLINE(FILTER(平安分时关注,20),X_12,X_13,0,0),COLOR00FFFF;
DRAWTEXT(FILTER(平安分时追涨,20),现价,'←追涨'),COLORMAGENTA;
STICKLINE(FILTER(平安分时追涨,20),X_12,X_13,0,0),COLORMAGENTA;
PA3:=BARSSINCE(平安分时追涨)+1;
首次追涨价:=REF(C,PA3-1),NODRAW;
追涨收益:(DYNAINFO(7)-首次追涨价)/首次追涨价*100,NODRAW;
DRAWTEXT_FIX(1,0.852,1-0.0,0,STRCAT(STRCAT('【追涨收益】',CON2STR(追涨收益,2)),'%')),COLORMAGENTA;
PA4:=BARSSINCE(平安分时关注)+1;
首次关注价:=REF(C,PA4-1),NODRAW;
关注收益:(DYNAINFO(7)-首次关注价)/首次关注价*100,NODRAW,COLORRED;
DRAWTEXT_FIX(1,0.852,1-0.098,0,STRCAT(STRCAT('【关注收益】',CON2STR(关注收益,2)),'%')),COLOR00FFFF;

量价:=(VOL/CLOSE)/3;
B2:=SUM((IF(((量价>0.20) AND (CLOSE>(REF(CLOSE,1)))),量价,0)),0);
B3:=SUM((IF(((量价>0.20) AND (CLOSE<(REF(CLOSE,1)))),量价,0)),0);
B6:=B2+B3;DD1:=1;比:=B2/B3;
BBB1:=STRCAT(STRCAT('买 ',CON2STR((100*B2)/B6,0)),'%');
BBB2:=STRCAT(STRCAT('卖 ',CON2STR((100*B3)/B6,0)),'%');
BBB3:=STRCAT(STRCAT('差 ',CON2STR((100*(B2-B3))/B6,0)),'%');
DRAWTEXT_FIX(DD1=1,0.500,0.83,0,BBB1),COLORRED;
DRAWTEXT_FIX(DD1=1,0.500,0.90,0,BBB2),COLORGREEN;
DRAWTEXT_FIX(DD1=1,0.500,0.999,0,BBB3),COLOR00FFFF;


 

股票公式栏目导航

本类热门

相关公式