通达信分时攻击起爆指标 源码 贴图

2022-12-26 10:56:00来源:本站整理浏览:1924

通达信分时攻击起爆指标 源码 贴图

通达信分时攻击起爆指标 源码 贴图

通达信分时攻击起爆指标 源码 贴图


{起爆时间}
委买:DYNAINFO(58)*C/100,LINETHICK0;
委卖:DYNAINFO(59)*C/100,LINETHICK0;
委差:DYNAINFO(58)-DYNAINFO(59)*C/100,LINETHICK0;
多空比:=DYNAINFO(58)/DYNAINFO(59)*C/100,LINETHICK0;
昨收:=DYNAINFO(3);
HH:=DYNAINFO(5);
LL:=DYNAINFO(6);
FK:=MAX(HH-昨收,昨收-LL)*0.1;
ZS:=昨收-FK*3.2;
Q1:=昨收-FK*3.22;
Q2:=昨收-1*FK*3.22;
Q3:=昨收-5*FK*3.2;
TJ:=FILTER(C,239)>0,NODRAW;
TJJ:=SUM(TJ,0),NODRAW;
TJA:=CONST(TJJ),NODRAW;
流通盘:=CAPITAL*100/100000000,NODRAW;
资金流入:=SUM(IF(C>REF(C,1),V,0),FROMOPEN),LINETHICK3,COLORRED;
资金流出:=-SUM(IF(C<REF(C,1),V,0),FROMOPEN),LINETHICK3,COLORWHITE;
资金出入:=资金流入+资金流出,LINETHICK3,COLORGREEN;
HD:=HHV(资金出入,2400);
LD:=LLV(资金出入,2400);
最高:=CONST(HD),NODRAW;
最低:=CONST(LD),NODRAW;
HLMAX:=最高;
HLMIN:=最低;
HLMN1:=(HLMAX+HLMIN)/2;
HLMN2:=HLMAX-HLMIN;
HLMN3:=(100-0)/2*1.3;
HLMN4:=(100-0)/1*1.3;
中间价轴:=(50-HLMN3)*HLMN2/HLMN4+HLMN1;
轴差:=最高-最低;
DRAWBAND(资金出入,RGB(150,0,150),0,RGB(0,100,0));
资金流量:=资金出入,COLORFFFFFF,LINETHICK1;
资金比:=资金出入/SUM(V,FROMOPEN)*100,COLOR00FFFF,LINETHICK1;
资金流量比:=IF(资金比>=0,(资金比+100)/2,100-ABS((资金比-100)/2));
攻击量:=((HSL*0.50+REF(HSL,1)*0.33)+(REF(HSL,2)*0.17))*SUM(C,FROMOPEN)/FROMOPEN;
攻击量A:=SUM(IF(C>REF(C,1),攻击量*V,0),FROMOPEN),COLOR0000FF,LINETHICK0;
攻击量B:=-SUM(IF(C<REF(C,1),攻击量*V,0),FROMOPEN),COLOR00FF00,LINETHICK0;
攻击流量:攻击量A+攻击量B,COLORSTICK;
NOTEXT攻击线:攻击流量,COLORYELLOW,LINETHICK1;
攻击比:攻击流量/SUM(V,FROMOPEN)*100,COLORRED,LINETHICK1;
资金攻击度:IF(攻击比>=0,(攻击比+50),100-ABS((攻击比-50))),COLORMAGENTA;
{STICKLINE(资金流量A>0,资金流量A,0,1,0),COLOR0000FF;
STICKLINE(资金流量B<0,资金流量B,0,1,0),COLORFF0000;}
DRAWRECTREL(110,10,400,90,RGB(0,75,200));
DRAWRECTREL(110,10,250,90,RGB(0,250,50));
DRAWRECTREL(110,10,100+CONST(资金流量比*300/100),90,RGB(200,50,0));
DRAWTEXT_FIX(1,0.000,0.00,0,STRCAT(STRCAT('【资金流量比】',CON2STR(资金流量比,2)),'%买')),COLORYELLOW;
DRAWRECTREL(610,10,900,90,RGB(0,75,200));
DRAWRECTREL(610,10,750,90,RGB(0,250,50));
DRAWRECTREL(610,10,600+CONST(资金攻击度*300/100),90,RGB(175,50,0));
DRAWTEXT_FIX(1,0.500,0.00,0,STRCAT(STRCAT('【资金攻击度】',CON2STR(资金攻击度,2)),' %买')),COLORYELLOW;
量:=VOL,VOLSTICK;{股票下载网WWW.GPXIAZAI.COM}
五日量:=MA(量,5),COLORWHITE;
TT:=BARSCOUNT(C);{取得有效收盘价}
均价黄:=SUM(C*V,TT)/SUM(V,TT);{分时均线的取值}
量两步:=MA(V,5)>REF(MA(V,5),1) AND REF(MA(V,5),1)>REF(MA(V,5),2);
价两步:= C>=REF(C,1) AND REF(C,1)>REF(C,2);
价上岗量破5:=C>均价黄 AND V>MA(V,5);
量起爆:=V>=REF(V,1)*1;
价创新高:=C>=HHV(C,0);
量创新高:=V>=HHV(V,0);
对昨日涨幅:=(C/DYNAINFO(3)-1)*100<=1.50;{涨幅控制2个点以内}
每日一点:=量两步 AND 价两步 AND 价上岗量破5 AND 量起爆 AND 价创新高 AND 量创新高 AND 对昨日涨幅;
{计算收益、已爆分钟}
VV:=BARSSINCE(每日一点)+1;
首次起爆价:=REF(C,VV-1),NODRAW;
起爆收益:(DYNAINFO(7)-首次起爆价)/首次起爆价*100,NODRAW;
起爆时间:=REF(TIME/10000,VV),NODRAW;
已爆分钟:=VV-1,NODRAW;
{画出底线和红球}
首次起爆量:=REF(VOL,VV-1);
MMA30:=EMA(CLOSE,30);
强弱界定:=IF(PERIOD=0 ,EMA(CLOSE,900),DRAWNULL);
分时均价线:=SUM(C*V,240)/SUM(V,240),COLORYELLOW,LINETHICK2;
GHYJKU:=BETWEEN(CLOSE/(SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(VOL*100,BARSCOUNT(CLOSE))),1.05,0.95);
VBNH:=IF(0,MA(CLOSE,BARSCOUNT(CLOSE)),(SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(VOL*100,BARSCOUNT(CLOSE))));
二十☆:=EXPMA((CLOSE/VBNH),20),COLORRED,LINETHICK1;
六十:=EXPMA((CLOSE/VBNH),60),COLORLIGREEN,LINETHICK1;
FAA:=BARSLAST(TIME=100000);
FCC:=REF(HHV(C,0),FAA+1);
FVV:=REF(HHV(V,0),FAA+1);
ZF:=FCC/DYNAINFO(3)<1.05;
XG1:=CROSS(C,FCC) AND V>FVV AND ZF,COLORWHITE;
FAA1:=BARSLAST(TIME=110000);
FCC1:=REF(HHV(C,0),FAA1+1);
FVV1:=REF(HHV(V,0),FAA1+1);
ZF1:=FCC1/DYNAINFO(3)<1.05;
XG2:=CROSS(C,FCC1) AND V>FVV1 AND ZF1,COLORYELLOW;
突破:=XG1 OR XG2,COLORRED;
VT:=BARSSINCE(突破)+1;
首次突破价:=REF(C,VT-1),NODRAW;
突破收益:=(DYNAINFO(7)-首次突破价)/首次突破价*100,NODRAW;
拉升量:=IF(C>REF(C,1),VOL,0);
昨拉升最高值:=CONST(FINDHIGH(拉升量,FROMOPEN,240,1)),LINETHICK1,COLORMAGENTA;
今拉升最高值:=CONST(REF(HHV(拉升量,FROMOPEN),0)),COLORYELLOW,NODRAW;
攻击力度:=今拉升最高值/昨拉升最高值,NODRAW;
STICKLINE(FILTER(CROSS(拉升量,昨拉升最高值),30),最低+轴差*0.80,最低,1,0),COLORCYAN;
STICKLINE(每日一点,最低+轴差*0.65,最低,1,0),COLORMAGENTA;
STICKLINE(突破,最低+轴差*0.50,最低,1,0),COLORWHITE;
STICKLINE(FILTER(BARSLAST(C<MIN(MMA30,强弱界定))<=20 AND CROSS(C,MAX(MMA30,强弱界定)),30),最低,最低+轴差*0.2,1,0),COLORGREEN;
DRAWICON(FILTER(CROSS(拉升量,昨拉升最高值),30),最低+轴差*0.80,1);
DRAWICON(每日一点,最低+轴差*0.65,1);
DRAWICON(突破,最低+轴差*0.50,17);
DRAWICON(FILTER(BARSLAST(C<MIN(MMA30,强弱界定))<=20 AND CROSS(C,MAX(MMA30,强弱界定)),30),最低+轴差*0.2,9);
打压量:=IF(C<REF(C,1),VOL,0);{股票下载网WWW.GPXIAZAI.COM}
今打压最高值:=CONST(REF(HHV(打压量,FROMOPEN),0)),NODRAW;
DRAWTEXT(FILTER(CROSS(拉升量,今打压最高值),30),最低+轴差*0.80,'攻'),COLORMAGENTA;
DRAWTEXT(FILTER(CROSS(拉升量,今打压最高值),30),最低+轴差*0.60,'击'),COLORMAGENTA;
DRAWTEXT(每日一点,最低+轴差*0.65,'起爆'),COLORGREEN;
DRAWNUMBER(每日一点,最低+轴差*0.55,首次起爆价),COLORGREEN;
DRAWTEXT(突破,最低+轴差*0.50,'分时突破'),COLORWHITE;
DRAWNUMBER(突破,最低+轴差*0.40,首次突破价),COLORWHITE;
DRAWTEXT(FILTER(BARSLAST(C<MIN(MMA30,强弱界定))<=20 AND CROSS(C,MAX(MMA30,强弱界定)),30),最低+轴差*0.2,'关注'),COLORMAGENTA;
大单买:(SUM(IF(C>REF(C,1) AND V>4000,V/1000,0),0))*1500,COLORRED,LINETHICK3;
大单卖:(SUM(IF(C<REF(C,1) AND V>4000,V/1000,0),0))*1500,COLORGREEN,LINETHICK3;
DRAWTEXT(突破,最低+轴差*0.50,'分时突破'),COLORWHITE;
股价趋势:3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100000,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100000,5,1),3,1),COLORYELLOW;
VAR51:=(C/REF(C,1)-1)*100;
冲涨停:IF(CROSS(TIME<=093000,VAR51<=2 AND VAR51>=-2),10000,0),STICK,LINETHICK3;
DRAWTEXT((冲涨停 > 0),10950,'冲'),LINETHICK5,COLORYELLOW;
DRAWTEXT((冲涨停 > 0),10900,'涨'),LINETHICK5,COLORYELLOW;
DRAWTEXT((冲涨停 > 0),10850,'停'),LINETHICK5,COLORYELLOW;
HYJKU:=BETWEEN(CLOSE/(SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(VOL*100,BARSCOUNT(CLOSE))),1.05,0.95);
AVBNH:=IF(HYJKU=0,MA(CLOSE,BARSCOUNT(CLOSE)),(SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(VOL*100,BARSCOUNT(CLOSE))));
DRAWICON(CROSS(EXPMA((CLOSE/AVBNH),20),1.02),1.02+0.005,18);
STICKLINE(CROSS(EXPMA((CLOSE/AVBNH),20),1.02),1.02,1.025,4,0), , COLORMAGENTA;
DRAWTEXT(CROSS(EXPMA((CLOSE/AVBNH),20),1.02),1.02,'拉升'),COLORWHITE;
DRAWTEXT(CROSS(EXPMA((CLOSE/AVBNH),20),1.04),1.04,'可能涨停'),COLORWHITE;
STICKLINE(EXPMA((CLOSE/AVBNH),120)>1.003 ,1.03,1.039,1.0,0),COLORMAGENTA;
DRAWTEXT(CROSS(EXPMA((CLOSE/AVBNH),120),1.0029),1.028,'买进'),COLORWHITE;
DRAWICON(CROSS(EXPMA((CLOSE/AVBNH),120),1.0029),1.0326*1,13);
DRAWTEXT(CROSS(EXPMA((CLOSE/AVBNH),120),1.0029),1.036,'观察分时量'),COLORWHITE;
DRAWICON(CROSS(EXPMA((CLOSE/VBNH),60),EXPMA((CLOSE/VBNH),120)),EXPMA((CLOSE/VBNH),60)*1,1);
DRAWICON(CROSS(EXPMA((CLOSE/VBNH),20),1.02),1,18);

 

股票公式栏目导航

本类热门

相关公式