通达信筹码突破主图+筹码分布副图指标 源码 贴图

2022-04-20 09:13:00来源:本站整理浏览:1666

通达信筹码突破主图+筹码分布副图指标 源码 贴图

筹码分布副图源码:
LH:=COST(0.1);
HH:=COST(99.9);
CP:=(HH-LH)/10;{WWW.GPXIAZAI.COM}
红色筹码:INTPART((WINNER(LH+CP*3)-WINNER(LH))*100),COLOR5533FF,LINETHICK3;
蓝色筹码:INTPART((WINNER(LH+CP*7)-WINNER(LH+CP*4))*100),COLORCC6600,LINETHICK3;
绿色筹码:INTPART((WINNER(HH)-WINNER(LH+CP*7))*100),COLOR009933,LINETHICK3;

通达信筹码突破主图+筹码分布副图指标 源码 贴图

通达信筹码突破主图+筹码分布副图指标 源码 贴图


MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA60:MA(CLOSE,60);
MA120:MA(CLOSE,120);
MA250:MA(CLOSE,250);
成交量显示:=0;
F1:=COST(90),COLOR009955,LINETHICK2;
F2:=COST(70),COLOR055599,LINETHICK2;
F3:=COST(50),COLOR055500,LINETHICK2;
F4:=COST(30),COLOR050099,LINETHICK2;
F5:=COST(2),COLOR050099,LINETHICK2;
低位筹码:=INTPART(COST(2)*100)/100,COLOR050099,LINETHICK2;

筹码牛熊:EMA((F1+F2+F3+F4+F5)/5,3),COLORYELLOW,LINETHICK3;

大阳:=(C-REF(C,1))/REF(C,1)*100;
涨幅:=(C-LLV(C,60))/LLV(C,60)*100;

LH:=COST(0.1);
HH:=COST(99.9);
CP:=(HH-LH)/10;

COST97:=INTPART(COST(97)*100)/100;
UP97:=(COST97-REF(COST97,1))/REF(COST97,1)*100;

筹码突破:=大阳>8 AND 涨幅<60 AND ((CROSS(C,COST97) AND UP97>2) OR WINNER(C)*100>98) AND (WINNER(LH+CP*4)-WINNER(LH))*100>10;
STICKLINE(筹码突破,OPEN,CLOSE,2.4,0),COLORYELLOW;
DRAWICON(筹码突破,LOW*0.97,26);

跌幅:=(C-HHV(C,60))/HHV(C,60)*100;
低吸:=FILTER((C-COST(2))/COST(2)*100<3 AND C>低位筹码 AND 低位筹码>=REF(低位筹码,1) AND 跌幅<-10,10);

STICKLINE(低吸,OPEN,CLOSE,2,0),COLORYELLOW;
DRAWICON(低吸,LOW*0.97,38);

DX:=BARSLAST(低吸);
ZY:=CROSS(COUNT(C<REF(C,DX),DX),0.5) AND DX<5;
DRAWICON(ZY,H*1.01,39);
DDXX:=BARSLAST(ZY);{WWW.GPXIAZAI.COM}
ZYY:=CROSS(COUNT(C>REF(C,DX),DDXX),0.5) AND DX>DDXX AND DDXX<20;
DRAWICON(ZYY,LOW*0.97,41);

DRAWNUMBER(CURRBARSCOUNT=1 AND C>0,筹码牛熊,(C-筹码牛熊)/筹码牛熊*100),COLORWHITE;

{DG-V}
GH:=48;GF:=48;
AAA:=CONST(LLV(L,GH))*0.85;
AV:=(V/((EMA(VOL,250)/EMA(C,250))*GF));
TC:=C/AV;TH:=H/AV;TL:=L/AV;TO:=O/AV;
ZB:=AV/((TH-TL)*2-ABS(TC-TO));
ZM:=IF(TC>TO,ZB*(TH-TL),IF(TC<TO,ZB*((TH-TO)+(TC-TL)),AV/2));
ZP:=IF(TC>TO,0-ZB*((TH-TC)+(TO-TL)),IF(TC<TO,0-ZB*(TH-TL),0-AV/2));
STICKLINE(C>O AND 成交量显示=1,AV+AAA,ZM+AAA,0.5,0),COLOR7777FF;
STICKLINE(C>O AND 成交量显示=1,AAA,ZM+AAA,0.5,0),COLOR7777FF;
STICKLINE(C<O AND 成交量显示=1,AV+AAA,ZM+AAA,0.5,0),COLOR00DD33;
STICKLINE(C<O AND 成交量显示=1,AAA,ZM+AAA,0.5,0),COLOR00DD33;

 

股票公式栏目导航

本类热门

相关公式