通达信跟庄四线主图指标 蓝黄飘带 买卖提示 源码 贴图

2022-06-22 09:16:00来源:本站整理浏览:478

通达信跟庄四线主图指标 蓝黄飘带 买卖提示 源码 贴图

通达信跟庄四线主图指标 蓝黄飘带 买卖提示 源码 贴图

通达信跟庄四线主图指标 蓝黄飘带 买卖提示 源码 贴图


A1:=ABS(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,23))/EMA(CLOSE,23));
A2:=DMA(((2.15*CLOSE+LOW+HIGH)/4),A1);
金线王:EMA(A2,200)*1.118 ,DOTLINE,COLORWHITE;

变1:EMA(CLOSE,35),LINETHICK2,COLORYELLOW;
金1:IF(变1>REF(变1,1),变1,DRAWNULL),COLORMAGENTA,LINETHICK2;
空1:IF(变1<REF(变1,1),变1,DRAWNULL),COLORGREEN,LINETHICK2;


{跟庄到顶,无未来}

U:=5;Y:=20;

趋势:MA(C,U);

角:ATAN((趋势/REF(趋势,1)-1)*100)*180/3.1416,NODRAW;

BIAS5:(CLOSE-MA(CLOSE,Y))/MA(CLOSE,Y)*100,NODRAW;

上升:IF(趋势>REF(趋势,1),趋势,DRAWNULL),COLORRED,LINETHICK3;

下降:IF(趋势<REF(趋势,1),趋势,DRAWNULL),COLORCYAN,LINETHICK3;


{牛熊线,紫色和绿色,无未来}
突破A:=REF(EMA(C,12),1);

A1X:=(EMA(C,10)-突破A)/突破A*100;

上轨通道1:(1+2/100)*DMA(CLOSE,ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20)),NODRAW,COLORBLUE,LINETHICK2;

下轨通道2:(1-6/100)*DMA(CLOSE,ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20)),NODRAW,COLORRED,LINETHICK2;

SSL:=EMA(CLOSE,3);

MMV:=EMA(((SLOPE(CLOSE,22) * 20) + CLOSE),55);

MM:=MA(MMV,1);

SA:=(MM*0.985);

SS:=(MA(CLOSE,5));

DD:=(MA(CLOSE,13));

GG:=(MA(CLOSE,21));

牛熊分界线:=IF(((SSL>MM)),MM,SA),LINETHICK3,COLORFF00FF;

熊线:=IF(SSL<MM,牛熊分界线,DRAWNULL),LINETHICK2,COLORGREEN;

{游资操盘线,黄蓝带色色}
P0:=MA(INDEXC,34);
P1:=(55*P0+34*REF(P0,1)+21*REF(P0,2)+13*REF(P0,3)+8*REF(P0,4)+5*REF(P0,5)+3*REF(P0,6)+2*REF(P0,7)+REF(P0,8)+REF(P0,9))/143;
P2:=REF(P1,1);
H0:=MA(C,6);
H1:=(55*H0+34*REF(H0,1)+21*REF(H0,2)+13*REF(H0,3)+8*REF(H0,4)+5*REF(H0,5)+3*REF(H0,6)+2*REF(H0,7)+REF(H0,8)+REF(H0,9))/143;
H2:=REF(H1,1);{WWW.GPXIAZAI.COM}
游资资金:0.5*(H1+H2),NODRAW,COLORYELLOW;
DRAWBAND(H1,RGB(255,255,0),H2,RGB(0,0,255));


{通达信K线高亮指标
指标配色优美,支持注册制前后的涨幅高亮,
涨幅大于10%也高亮,跌停、炸板也有提示
结合同通达信涨停插件使用效果更佳,
插件地址 百度搜索“犀利猫”,进入首页找:通达信涨停插件
黄色:涨停,
橙色:涨幅大于10个点未涨停,
深橙色:涨幅大于20个点未封板,
绿色:跌停或跌幅大于10个点,
浅紫色:炸板阳线,
深紫色:炸板阴线,
白色虚线:现价线
竖线分割:创业板改革日期}
{均线,均线可以根据需要修改}

ZDJS:=IF(CODELIKE('880005'), 1, 0);
M5:=IF(ZDJS=0,MA(C,5),DRAWNULL);
M10:=IF(ZDJS=0,MA(C,10),DRAWNULL);
M20:=IF(ZDJS=0,MA(C,20),DRAWNULL);
M40:=IF(ZDJS=0,MA(C,40),DRAWNULL);
M250:=IF(ZDJS=0,MA(C,250),DRAWNULL);

{下一行是板块调用,也可以改为扩展数据调用,例如 EXTERNSTR(0,1) }
DRAWTEXT_FIX(1,0.003,0.02,0, STRCAT(HYBLOCK,STRCAT(' + ', STRCAT(GNBLOCK,STRCAT('+ ', FGBLOCK)))));

{涨跌家数880005 指标:情绪高低潮分割线}
N1:DRAWSL(ZDJS=1,3200,0,1000,1), COLORRED;
N2:DRAWSL(ZDJS=1,720,0,1000,1), COLORGREEN;


{现价线}
N:CONST(C), COLORBLACK, POINTDOT;


{填充线宽度}
W1:=3;
W0:=0;

{判断涨跌幅限制,涨跌停价格}
CYB:=IF(INBLOCK('创业板'), 1, 0);
ZDF:=IF(INBLOCK('科创板'),0.2,IF(INBLOCK('ST板块'), 0.05, 0.1));
ZT:=ZTPRICE(REF(CLOSE,1), ZDF);
DT:=DTPRICE(REF(CLOSE,1), ZDF);
ZT1:=ZTPRICE(REF(CLOSE,1), 0.1);
ZT2:=ZTPRICE(REF(CLOSE,1), 0.2);
DT1:=DTPRICE(REF(CLOSE,1), 0.1);
DT2:=DTPRICE(REF(CLOSE,1), 0.2);

{非创业板涨跌停}
NOCYB:=CYB=0 AND ZDJS=0;
STICKLINE((NOCYB AND C>=ZT AND C=H), O, C, W1, 0),COLOR007FFF;
STICKLINE((NOCYB AND C<=DT AND C=L), O, C, W1, 0),COLORGREEN;
STICKLINE((NOCYB AND L<=DT AND C<ZT AND C>L), L, C, 0, 0),COLORGREEN;{曾跌停阳线}

{炸板}
STICKLINE((NOCYB AND C<ZT AND H=ZT AND C>DT AND C<O), O, C, W1, 0), COLORFF4D88;
STICKLINE((NOCYB AND C<ZT AND H=ZT AND C>O), O, C, W1, 0), COLORFF4DFF;

{创业板改革日分割线}
GGR:=1200824;{改革日}
STICKLINE(DATE=GGR AND (CYB=1 OR CODELIKE('8808')), CONST(LLV(L,120)), CONST(HHV(H,120)), W0, 0),COLOR5C979C;

{创业板涨停跌停}
STICKLINE((CYB=1 AND DATE>=GGR AND C>=ZT2 AND C=H), O, C, W1, 0), COLOR007FFF;
STICKLINE((CYB=1 AND DATE<GGR AND C>=ZT AND C=H), O, C, W1, 0), COLOR007FFF;
STICKLINE((CYB=1 AND DATE<GGR AND C<=DT AND C=L), O, C, W1, 0), COLORGREEN;

{炸板}
STICKLINE((CYB=1 AND DATE<GGR AND C<ZT AND H=ZT AND C>DT AND C<O), O, C, W1, 0), COLORFF4DFF;
STICKLINE((CYB=1 AND DATE<GGR AND C<ZT AND H=ZT AND C>O), O, C, W1, 0), COLORFF4DFF;
STICKLINE((CYB=1 AND DATE>=GGR AND C<ZT AND H=ZT2 AND C>DT AND C<O), O, C, W1, 0), COLORFF4DFF;

{所有板块:涨跌幅大于10个点}
STICKLINE((C>ZT1 AND C<ZT2 AND C>O AND ZDJS=0), O, C, W1, 0), COLOR00AAFF;
STICKLINE((C<H AND C>ZT2 AND C>O AND ZDJS=0), O, C, W1, 0), COLOR0066CC;
STICKLINE((C<=DT1 AND C<O AND ZDJS=0), O, C, W1, 0), COLORGREEN;


{涨停分类}
个线:=EMA(EMA(CLOSE,30),9);
大线:=EMA(EMA(INDEXC,45),9);
个股1:=CLOSE/个线*100;
大盘1:=INDEXC/大线*100;
GGQD:=(个股1-大盘1);
ND1:=REF(BARSLAST((C-REF(C,1))/REF(C,1)*100>9.6 AND C=H),1)+1;
回光返照:=COUNT(CROSS(MA(C,15),MA(C,5)),ND1)=0 AND HHV(GGQD,20)>23 AND MA(C,5)>MA(C,30) AND GGQD<HHV(GGQD,30) AND GGQD>5 AND (C-REF(C,1))/REF(C,1)*100>9.6 AND C=H;
ZDT:=(C-REF(C,1))/REF(C,1)*100>8.5,COLORWHITE;
开盘:=IF(REF(ZDT,1)>0 ,(O-REF(C,1))/REF(C,1)*100,0),NODRAW;
BIAS1 :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2 :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
BIA:=(BIAS1-BIAS2);
BIS:=LLV(BIAS1,3);
超跌涨停:=ZDT>0 AND BIS<0 AND BIA>5 AND MA(C,5)<MA(C,60);


MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20) ;
MA30:=MA(C,30);
MA60:=MA(C,34);
F1:=(MA5-MA10)/MA10*100;
F2:=(MA10-MA20)/MA10*100;
F3:=(MA20-MA60)/MA10*100;
拉升涨停:=F1>1 AND F2>3 AND F3>0 AND ZDT>0,COLORRED;
AD1:=REF(C,20)=HHV(C,2*20+1);BD1:=FILTER(AD1,20);

RSI1:=SMA(MAX(CLOSE-REF(CLOSE,1),0),5,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),5,1)*100;
钝化涨停:=ZDT>0 AND RSI1=HHV(RSI1,5) AND RSI1>80;
钝化涨停1:=GGQD>15 AND ZDT>0 AND RSI1=HHV(RSI1,5) AND RSI1>80 AND REF(GGQD>15 AND ZDT>0 AND RSI1=HHV(RSI1,5) AND RSI1>80,1)=0;
新股首次:=COUNT(ZDT>0,BARSCOUNT(C))=1 AND ZDT>0 AND FINANCE(42)<100;

DRAWTEXT(回光返照,L*1.1,' 回光返照'),COLORCYAN;
DRAWTEXT(新股首次,L*0.96,'新股首次'),COLORMAGENTA;
DRAWTEXT(拉升涨停,L*1.05,' 拉升'),COLORFF00FF;


Q1:MA(CLOSE,13),NODRAW,LINETHICK5;
Q2:MA(CLOSE,17),NODRAW,LINETHICK5;
QQ1:=C-REF(C,1);{WWW.GPXIAZAI.COM}
GGGH1:=100*EMA(EMA(QQ1,6),6)/EMA(EMA(ABS(QQ1),6),6);
GGGH2:=IF(LLV(GGGH1,2)=LLV(GGGH1,7) AND COUNT(GGGH1<0,2) AND CROSS(GGGH1,MA(GGGH1,2)),1,0),COLORRED,LINETHICK0;
GGGH3:=IF(HHV(GGGH1,2)=HHV(GGGH1,7) AND COUNT(GGGH1>50,2) AND CROSS(MA(GGGH1,2),GGGH1),1,0),COLOR00FF00,LINETHICK0;
DRAWTEXT(FILTER(GGGH3=1,1),HIGH*1.005,'↓卖'),COLOR00FF00;

QN1:=42;
QN2:=21;
QN3:=89;
C1:=C/REF(C,1);
MX:=EMA(SLOPE(C,QN2)*20+C,QN1),LINETHICK1,COLORBLACK;
MXR:=MX/REF(MX,1);
MR:=SLOPE(MX,2);
MRD:=CROSS(0,MR);
TMR:=BARSLAST(MRD);
MRR:=REF(MX,TMR);
MN3:=HHV(MRR,QN3);
MFD:=CROSS(MR,0);
TMF:=BARSLAST(MFD);
MFT:=REF(MX,TMF);
ROU:=CROSS(MX,MN3)&&MX/MFT<1.25&&MX/LLV(MX,55)<1.35;
TRR:=BARSLAST(ROU);
DRAWTEXT(MX/MRR>=1.55&&MXR>1.034&&CROSS(REF(MR,1),MR),H*1.015,'当心'),COLORGREEN;


 

股票公式栏目导航

本类热门

相关公式