通达信分时BS突破主图指标 源码 贴图

2022-10-24 10:11:00来源:本站整理浏览:2288

通达信分时BS突破主图指标 源码 贴图

通达信分时BS突破主图指标 源码 贴图

通达信分时BS突破主图指标 源码 贴图


{涨停时间}
DRAWNUMBER(FILTER(CROSS(C,DYNAINFO(3)*1.1-0.01),60),C*0.99,TIME),COLORYELLOW;
{所属板块}
DRAWTEXT_FIX(C>0,0.09,0.78,0,DYBLOCK),COLORYELLOW,LINETHICK2;{地域}
DRAWTEXT_FIX(C>0,0.35,0.78,0,HYBLOCK),COLORYELLOW,LINETHICK2;{行业}
DRAWTEXT_FIX(C>0,0.09,1,0,GNBLOCK),COLORCYAN,LINETHICK2;{概念}
DRAWICON(FILTER(CROSS(C,DYNAINFO(3)*1.1-0.01),60),C,1);
DRAWNUMBER(FILTER(CROSS(C,DYNAINFO(3)*1.1-0.01),60),C*0.99,TIME),COLORWHITE;
{划线与买卖拉冲突标记}
XG:HHV(H,480),DOTLINE,COLORCYAN;
STICKLINE(FILTER(CROSS(C,REF(XG,1)),10) AND C>REF(XG,1),C*0.998,C,1,0),COLORWHITE;{和突配套的白色柱子}
DRAWTEXT(FILTER(CROSS(C,REF(XG,1)),10) AND C>REF(XG,1),C*0.995,'突')AND C<ZTPRICE(REF(CLOSE,1),0.1),COLORYELLOW;
RQ:=DATETODAY(DATE)-DATETODAY(REF(DATE,TOTALBARSCOUNT-CURRBARSCOUNT))+1;
JY:=BARSLAST((RQ-REF(RQ,1))!=WEEKDAY-REF(WEEKDAY,1) OR TOTALBARSCOUNT-CURRBARSCOUNT=0)+1;
MA01:=REF(C,JY);GOODGUPIAO:SMA(MAX(CLOSE-C,0),7,1)/SMA(ABS(CLOSE-C),7,1)*100,NODRAW;
MA02:=REF(MA01,JY);
MA03:=REF(MA02,JY);
MA04:=REF(MA03,JY);
MA05:=REF(MA04,JY);
MA6:=REF(MA05,JY);
MA7:=REF(MA6,JY);
MA8:=REF(MA7,JY);
MA9:=REF(MA8,JY);
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:L1+P1*8/9,COLORLIRED,DOTLINE;
支撑:L1+P1*0.5/9,COLORGREEN,DOTLINE;

XX:=SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(V*100,BARSCOUNT(CLOSE));
主力:=EXPMA(CLOSE/XX,20);
大户:=EXPMA(CLOSE/XX,60);
散户:=EXPMA(CLOSE/XX,120);
底:=1;
中:=1.022,NODRAW;
高:=1.033;

DRAWICON(LONGCROSS(支撑 ,C,2),C-0.01,7);
STICKLINE(LONGCROSS(支撑,C,2),C,阻力,0,-1),COLORCYAN;

DRAWICON(LONGCROSS(C,阻力,2)AND C<ZTPRICE(REF(CLOSE,1),0.1),C+0.01,8);
STICKLINE(LONGCROSS(C,阻力,2),C,支撑,0,-1),COLORRED;

{流通市值}{公式网WWW.GPXIAZAI.COM}
DRAWTEXT_FIX(1,0.60,0.78,0,STRCAT(STRCAT('流通市值:',CON2STR(FINANCE(46)*C/100000000,2)),'亿元'))COLORYELLOW;

DRAWTEXT_FIX(1,0.60,0.55,0,STRCAT(STRCAT('昨日换手:',CON2STR(REF(V,1)#DAY/FINANCE(7)*10000,2)),'%'))COLORYELLOW;

{竞价情况}
JJCJL:=DYNAINFO(15)/DYNAINFO(4)/100;
JJJEDW:=IF(DYNAINFO(15)>10000,'万元','元');
JJJE:=IF(DYNAINFO(15)>10000,CON2STR(DYNAINFO(15)/10000,1),CON2STR(DYNAINFO(15),1));
JJJE1:=STRCAT(JJJE,JJJEDW);
JJ:=STRCAT('竞价量额:',STRCAT(CON2STR(JJCJL/10000,2),'万手'));
JJ1:=STRCAT(JJ,' = ');

DRAWTEXT_FIX(1,0.09,0.65,0,STRCAT(JJ1,JJJE1))COLORMAGENTA;{竞价量额位置}
{DRAWTEXT_FIX(1,0.95,0.50,0,STRCAT('占昨成交:',STRCAT(CON2STR(DYNAINFO(15)/分时引用.昨日额#DAY*100,2),'%')))COLORYELLOW;}

今日竞价股数:=DYNAINFO(15)/DYNAINFO(4);


 

股票公式栏目导航

本类热门

相关公式