通达信金黄三角主图指标 源码 贴图

2024-07-03 10:33:00来源:本站整理浏览:532

通达信金黄三角主图指标 源码 贴图

通达信金黄三角主图指标 源码 贴图

通达信金黄三角主图指标 源码 贴图

新SAR100:=NEWSAR(1,100);
新SAR10:=NEWSAR(1,10);
新SAR5:=NEWSAR(1,5);
新SAR1:=NEWSAR(1,1);
{DRAWBAND(新SAR10,RGB(41,36,33),新SAR100+0.02,RGB(41,36,33));}
DRAWBAND(新SAR10,RGB(47,79,79),新SAR100+0.02,RGB(47,79,79));
前20内高:=HHV(C,20);{公式网 WWW.GPXIAZAI.COM}
昨前高:CONST(REF(前20内高,2)),COLOR49B9FD;
XX:=DRAWLINE(CURRBARSCOUNT=5,昨前高*0.9,CURRBARSCOUNT=1,昨前高,0);
DRAWBAND(昨前高,RGB(253,185,73),XX,RGB(0,0,0));
XX1:=DRAWLINE(CURRBARSCOUNT=9,昨前高,CURRBARSCOUNT=5,昨前高*0.9,0);
DRAWBAND(昨前高,RGB(253,185,73),XX1,RGB(0,0,0));
新SAR101:NEWSAR(1,100),COLORLIGRAY;
DRAWRECTREL(780,850,920,980,90);
DRAWTEXT_FIX(1,0.81,0.9,0,'两山凹陷处有大阳'),COLORYELLOW;
DRAWRECTREL(680,50,820,170,90);
DRAWTEXT_FIX(1,0.70,0.10,0,'黄金三角上是望高台'),COLORYELLOW;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
反转:新SAR101<REF(新SAR101,1) AND REF(新SAR101,1)<REF(新SAR101,2) AND REF(新SAR101,2)<REF(新SAR101,3) AND C>新SAR101,NODRAW,COLORRED;{选股时去掉前面的等号}
DRAWICON(反转,L*0.985,38);
M72:MA(C,72),COLORLIGREEN,LINETHICK2;
IF(M72>REF(M72,1),M72,DRAWNULL),COLORRED,LINETHICK2;
M240:MA(C,240),COLORLICYAN;
MSAR24:MA(新SAR100,24),COLORMAGENTA;
{13天变盘时间窗}
AA:=BARSCOUNT(C);
AH:=HHV(H,200);
AL:=LLV(L,200);
A0:=(AH-AL)/150;
B1:=L-A0;
STICKLINE((AA+0)/13=FLOOR((AA+0)/13),B1,B1-A0,4,0),COLORF00FF0;
DRAWTEXT((AA+0)/13=FLOOR((AA+0)/13),B1-A0,'时窗'),COLORF00FF0;
{老鼠仓}
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
老鼠仓:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(老鼠仓,LOW* 0.985,'△老鼠仓'),COLOR40CCFF;
{黄金柱}
C1:=(2*C+H+L+O)/5;
VAR11:=(8*C1+7*REF(C1,1)+6*REF(C1,2)+5*REF(C1,3)+4*REF(C1,4)+3*REF(C1,5)+2*REF(C1,6)+REF(C1,8))/36;
TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR11 AND C>REF(C,1);
LJL:=FILTER(TJ1,5);
STICKLINE(LJL,OPEN,CLOSE,0,1),COLORYELLOW;
DRAWTEXT(LJL,L,'←金柱'),COLORYELLOW;
DRAWTEXT(LJL,O+(C-O)*0.618,'------'),COLORYELLOW;{在黄金柱实体的0.618处画虚线}
CONST(C),POINTDOT,COLORLIGRAY;
{基本面}
DRAWTEXT_FIX(1,0.00,0.14,0,DYBLOCK),COLORYELLOW,LINETHICK2;
DRAWTEXT_FIX(1,0.00,0.00,0,'主题投资:'),COLORRED;
DRAWTEXT_FIX(1,0.075,0.00,0,EXTERNSTR(0,1)),COLORLIMAGENTA;
DRAWTEXT_FIX(1,0.00,0.08,0,'主营业务:'),COLORFF00FF;
DRAWTEXT_FIX(1,0.075,0.08,0,EXTERNSTR(0,2)),COLORFF00FF;
DRAWTEXT_FIX(1,0.06,0.14,0,EXTERNSTR(0,3)),COLORLIGRAY;
DRAWTEXT_FIX(1,0.01,0.20,0,EXTERNSTR(0,4))COLORCYAN;


 

 

股票公式栏目导航

本类热门

相关公式