通达信量化强度主图指标 源码 贴图

2024-06-06 10:23:00来源:本站整理浏览:457

通达信量化强度主图指标 源码 贴图

通达信量化强度主图指标 源码 贴图

通达信量化强度主图指标 源码 贴图

X1:=IF(MA(C,5)>MA(C,10),20,0);
X2:=IF(MA(C,20)>MA(C,60),10,0);
X3:=IF(KDJ.J>KDJ.K,10,0);
X4:=IF(MACD.DIF>MACD.DEA,10,0);
X5:=IF(MACD.MACD>0,10,0);
X6:=IF(V>MA(V,60),10,0);
X7:=IF(WINNER(C)>0.5,10,0);
X8:=IF(C/REF(C,1)>1.03,10,0);
XX:=X1+X2+X3+X4+X5+X6+X7+X8;
ZTJ:=ZTPRICE(REF(C,1),0.1);
涨停板1:=FINANCE(3)=1&&C=ZTPRICE(REF(C,1),0.1);
涨停板2:=FINANCE(3)=3&&C=ZTPRICE(REF(C,1),0.2);
涨停板:=涨停板1 OR 涨停板2;
K线实体:=ABS(C-O);
倍量:=V/REF(MA(V,5),1)>=2&&V/REF(V,1)>=1.2;
三倍量:=V/REF(V,1)>=2;
双倍量0:=倍量 OR 三倍量;
双倍量:=双倍量0&&C>O&&H=HHV(H,6)&&C>EMA(C,13)&&V=HHV(V,6);
建仓量:=TFILTER(双倍量&&K线实体>REF(K线实体,1),EVERY(V<MA(V,5),2),1);
JCZQ:=BARSLAST(建仓量);
拉升量:=双倍量&&NOT(建仓量)&&EXIST(建仓量,2);
试盘量:=建仓量 OR 拉升量;
位置要求:=L/EMA(C,13)<1.05;
红线上行:=EMA(C,13)>=REF(EMA(C,13),1);
SPX0:=H/REF(C,1)>=1.03&&双倍量&&H/C>1.005&&C/REF(C,1)>1.015&&位置要求
&&FINANCE(3)=1&&XX>=40;
SPX1:=H/REF(C,1)>=1.05&&双倍量&&H/C>1.005&&C/REF(C,1)>1.015&&位置要求
&&(FINANCE(3)=3 OR FINANCE(3)=4)&&XX>=40;
SPX2:=SPX0 OR SPX1;
SPX3:=SPX2&&NOT(EXISTR(SPX2,7,1))&&COUNT(涨停板,2)=0;
试盘K线:=FILTER(SPX3,5);
SPZQ:=BARSLAST(试盘K线);
试盘最高不破:=LAST(H<=REF(H,SPZQ),2,1);
洗盘不破:=COUNT(EMA(C,13)<REF(EMA(C,13),1),SPZQ)<2;
洗盘K00:=C<O&&H<REF(H,1);
洗盘K0:=EXIST(试盘K线,4)&&H<HHV(H,SPZQ+1)&&C>=EMA(C,13)&&L<=REF(C,SPZQ)&&C<O
&&COUNT(洗盘K00,SPZQ)<2&&C>EMA(C,13)&&V<HHV(V,SPZQ+1);
洗盘K:=TFILTER(洗盘K0,试盘K线,1);
XPZQ:=BARSLAST(洗盘K);
起爆K0:=EXISTR(试盘K线,10,2)&&C>REF(H,XPZQ)&&O<=REF(H,XPZQ)&&EXISTR(洗盘K,SPZQ,1)&&C>O
&&洗盘不破&&(H-C)/(C-O)<1.2&&COUNT(C>REF(H,XPZQ),XPZQ)=1;
起爆K1:=EXISTR(试盘K线,10,2)&&EVERY(C>=EMA(C,13),SPZQ)&&C>REF(H,XPZQ)&&O<REF(H,SPZQ)
&&EXISTR(洗盘K,SPZQ,1)&&涨停板&&COUNT(涨停板,10)=1&&L<REF(H,XPZQ);
起爆K2:=起爆K0 OR 起爆K1;
起爆K:=FILTER(起爆K2,5)&&XX>=70&&(H-MAX(O,REF(H,XPZQ)))>(MAX(O,REF(H,XPZQ))-L)*0.9;
拉板建仓:=FILTER(ZTPRICE(REF(C,1),0.1)&&建仓量&&COUNT(C=ZTJ,5)=1,10)&&COUNT(起爆K,SPZQ)=0&&NOT(试盘K线);
LBZQ:=BARSLAST(拉板建仓);
次日起爆0:=COUNT(试盘K线,2)=1&&COUNT(试盘K线,1)<1&&K线实体<REF(K线实体,1)&&V/REF(V,1)<1.8
&&NOT(涨停板)&&拉升量&&C/REF(C,1)>1.03;
次日起爆1:=COUNT(拉板建仓,2)=1&&COUNT(拉板建仓,1)<1&&K线实体<REF(K线实体,1)&&V/REF(V,1)<2
&&(C-O)/REF(C,1)>0.01&&NOT(涨停板)&&拉升量&&O/REF(C,1)>1.01&&H/REF(C,1)>1.09;
次日起爆:=次日起爆0 OR 次日起爆1;
龙回头:=FILTER(EXIST(拉板建仓,5)&&COUNT(EVERY(C<O,2),LBZQ)>0&&C>O&&O<REF(C,LBZQ)&&H>REF(C,LBZQ),3)&&NOT(涨停板);
二板龙头:=COUNT(拉板建仓,2)=1&&涨停板&&拉升量;
首板起爆:=EXIST(试盘K线,20)&&涨停板&&COUNT(涨停板,SPZQ)=1&&O<REF(C,SPZQ)&&C>REF(C,SPZQ);
倍量板:=FILTER(XX>50&&倍量&&涨停板&&K线实体>0.05&&COUNT(C=ZTJ,2)=1&&L/EMA(C,13)<1.05,5)&&NOT(起爆K);
倍量阳:=倍量板 OR 试盘K线;
DYZQ:=BARSLAST(倍量阳);
涨停回马枪0:=涨停板&&K线实体>0.05&&EXISTR(倍量阳,5,3)&&C>REF(H,DYZQ)&&COUNT(涨停板,2)=1
&&EXISTR(C<REF(C,1),4,1)&&EXISTR(L/EMA(C,13)<1.01,4,1)&&L<=REF(H,DYZQ)&&O/REF(H,DYZQ)<1.02;
涨停回马枪1:=涨停板&&K线实体>0.05&&EXISTR(试盘K线,5,3)&&C>REF(H,SPZQ)&&COUNT(涨停板,2)=1
&&EXISTR(C<REF(C,1),4,1)&&EXISTR(L/EMA(C,13)<1.01,4,1)&&L<=REF(H,SPZQ)&&O/REF(H,SPZQ)<1.02;
涨停回马枪:=涨停回马枪0 OR 涨停回马枪1;
ZH:=FILTER(涨停回马枪,5)&&NOT(起爆K);
{画粉柱}
画粉柱:=试盘K线;
STICKLINE(画粉柱,H,L,0,0),COLORFF55FF;
STICKLINE(画粉柱,C,O,3.1,0),COLOR880088;
STICKLINE(画粉柱,C,O,2.6,0),COLORAA00AA;
STICKLINE(画粉柱,C,O,1.9,0),COLORCC00CC;
STICKLINE(画粉柱,C,O,1.1,0),COLOREE00EE;
STICKLINE(画粉柱,C,O,0.2,0),COLORFF44FF;
{金柱}
画金柱:=起爆K OR ZH;
STICKLINE(画金柱,O,C,3.1,0),COLOR00AAFF;
STICKLINE(画金柱,O,C,2.1,0),COLOR00BBFF;
STICKLINE(画金柱,O,C,1.5,0),COLOR00CCFF;
STICKLINE(画金柱,O,C,1,0),COLOR00DDFF;
STICKLINE(画金柱,O,C,0.6,0),COLOR00EEFF;
STICKLINE(画金柱,O,C,0.2,0),COLOR00FFFF;
STICKLINE(画金柱,H,L,0,0),COLOR00FFFF;
{银柱}{爱股网 WWW.72GU.COM}
STICKLINE(FILTER(起爆K,5),O,L,0,0),COLORFFFFFF;
STICKLINE(FILTER(起爆K,5),O,MAX(O,REF(H,XPZQ)),3.1,0),COLOR555555;
STICKLINE(FILTER(起爆K,5),O,MAX(O,REF(H,XPZQ)),2.6,0),COLOR777777;
STICKLINE(FILTER(起爆K,5),O,MAX(O,REF(H,XPZQ)),1.9,0),COLOR999999;
STICKLINE(FILTER(起爆K,5),O,MAX(O,REF(H,XPZQ)),1.1,0),COLORCCCCCC;
STICKLINE(FILTER(起爆K,5),O,MAX(O,REF(H,XPZQ)),0.2,0),COLORFFFFFF;
起涨K:=H/REF(H,XPZQ)>0.9975&&H/REF(C,1)>1.02&&C>O&&EXIST(试盘K线,10)
&&EXIST(洗盘K,5)&&C<REF(H,XPZQ)&&NOT(EXIST(起爆K,3))&&L<REF(H,SPZQ)&&O<=REF(O,XPZQ)
&&H-C>(C-O)*0.3;
STICKLINE(起涨K OR 龙回头,H,L,0,0),COLOR0000FF;
STICKLINE(起涨K OR 龙回头,C,O,3.1,0),COLOR000099;
STICKLINE(起涨K OR 龙回头,C,O,2,0),COLOR0000BB;
STICKLINE(起涨K OR 龙回头,C,O,1,0),COLOR0000DD;
STICKLINE(起涨K OR 龙回头,C,O,0.2,0),COLOR0000FF;
首板0:=涨停板&&K线实体>0.05&&C>EMA(C,13)&&(C-EMA(C,13))>(EMA(C,13)-O)&&O<REF(C,SPZQ)&&C>REF(C,SPZQ);
首板:=首板0&&COUNT(涨停板,20)=1&&NOT(起爆K);
生命线:EMA(C,13),COLORGREEN,LINETHICK2;
趋势线2:=EMA(生命线,2);
趋势线3:=EMA(EMA(生命线,2),2);
QSGL:=生命线-趋势线3;
IF(生命线>REF(生命线,1),生命线,DRAWNULL),COLORRED,LINETHICK2;
DRAWTEXT(FILTER(起爆K,10),L*0.98,'↖起爆'),COLORWHITE;
DRAWTEXT(FILTER(起涨K,3),L*0.98,'↖起涨'),COLORWHITE;
DRAWTEXT(洗盘K,H*1.03,''),COLORWHITE;
DRAWTEXT(洗盘K,H*1.01,'↙震仓阴'),COLORWHITE;
DRAWTEXT(试盘K线&&NOT(起爆K),(C+O)/2,'试盘'),COLORWHITE;
DRAWTEXT(ZH,L*0.98,'↖涨停回马枪'),COLORWHITE;
DRAWTEXT(FILTER(倍量板&&NOT(涨停回马枪),5),L,'↖倍量首板'),COLORWHITE;
DRAWTEXT(龙回头,L,'↖龙回头'),COLORWHITE;
DRAWICON(起爆K OR ZH,L,9);
DRAWICON(起涨K,L,26);
KK1:=SUMBARS(洗盘K,1);
KK2:=SUMBARS(试盘K线,1);
STICKLINE(KK1<5&&KK2<7&&COUNT(起爆K,SPZQ)=0,REF(H,XPZQ),REF(H,XPZQ),3.1,0),COLORWHITE;
SWL:=(EMA(CLOSE,10)*7+EMA(CLOSE,20)*3)/10;
SWS:=DMA(EMA(CLOSE,20),MAX(1,100*(SUM(VOL,5)/(3*CAPITAL)))),COLORWHITE,DOTLINE;
JRH:=HHV(C,2);
JRL:=LLV(C,2);
MA3:=MA(CLOSE,3);
KMJ:=MA3;
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
VAR21:=(REF(VARD,1) AND KMJ AND KMJ<=REF(KMJ,2))*0+DATE;
VAR22:=(REF(VARD,1) AND KMJ>=REF(KMJ,1) AND KMJ<=REF(KMJ,2))*0+VAR21;
VAR23:=REF(VAR13,1) AND KMJ>=REF(KMJ,1) AND KMJ<=REF(KMJ,2)*0;
VAR24:=IF(VAR22>1230422,0,1);
VAR25:=REF(VAR14,1) AND KMJ<=REF(KMJ,1) AND KMJ>=REF(KMJ,2)*1;
VAR26:=REF(VAR15,1) AND KMJ>=REF(KMJ,1) AND KMJ<=REF(KMJ,2)*2;
CO:=(C-O);{公式网WWW.GPXIAZAI.COM}
E:=(HIGH+LOW+OPEN+2*CLOSE)/5;
阻力:=2*E-LOW;
支撑:=2*E-HIGH;
DRAWTEXT_FIX(C!=0,0.89,0.88,0,STRCAT('短期阻力位: ',STRCAT(CON2STR(阻力,2),' '))),COLORFFFF00;{COLOR346536;}
DRAWTEXT_FIX(C!=0,0.89,0.81,0,STRCAT('短期支撑位: ',STRCAT(CON2STR(支撑,2),' '))),COLORRED;{COLORBD005F;}
DRAWTEXT_FIX(V>O,0.87,0.95,0,STRCAT('九维量化强度值: ',STRCAT(CON2STR(XX,0),'分'))),COLOR00AAFF;


 

 

股票公式栏目导航

本类热门

相关公式