【通达信】麻烦将同花顺副图指标转成通达信的

2017-07-27 23:34:00来源:本站整理浏览:77

【通达信】麻烦将同花顺副图指标转成通达信的

主散力度
LC:=REF(CLOSE,1);
AA:=ABS(HIGH-LC);
BB:=ABS(LOW-LC);
CC:=ABS(HIGH-REF(LOW,1));
DD:=ABS(LC-REF(OPEN,1));
R:=IF(AA>BB AND AA>CC,AA+BB/2+DD/4,IF(BB>CC AND BB>AA,BB+AA/2+DD/4,CC+DD/4));
X:=(CLOSE-LC+(CLOSE-OPEN)/2+LC-REF(OPEN,1));
r:=16*X/R*MAX(AA,BB);
ASI1:=SUM(r,0);
STICKLINE(r>0,0,r*2.5,9,0),color0000ee;
STICKLINE(r<0,0,r*2.5,8,0,),colorgreen;
DDX1:SMA(MA(r,1,1),2,1)*5,colorwhite;
DDX8:=MA(DDX1,3),COLOR00FFFF;
轴:0,color664444,linethick1;

股票下载网www.gpxiazai.com解答:


{麻烦老师将同花顺副图指标转成通达信的}


LC:=REF(CLOSE,1);
AA:=ABS(HIGH-LC);
BB:=ABS(LOW-LC);
CC:=ABS(HIGH-REF(LOW,1));
DD:=ABS(LC-REF(OPEN,1));
R:=IF(AA>BB AND AA>CC,AA+BB/2+DD/4,IF(BB>CC AND BB>AA,BB+AA/2+DD/4,CC+DD/4));
X:=(CLOSE-LC+(CLOSE-OPEN)/2+LC-REF(OPEN,1));
R0:=16*X/R*MAX(AA,BB);
ASI1:=SUM(R0,0);
STICKLINE(R0>0,0,R0*2.5,9,0),COLOR0000EE;
STICKLINE(R0<0,0,R0*2.5,8,0),COLORGREEN;
DDX1:SMA(MA(R0,1),2,1)*5,COLORWHITE;
DDX8:=MA(DDX1,3),COLOR00FFFF;
轴:0,COLOR664444,LINETHICK1;

股票公式栏目导航

本类热门

相关公式