通达信笑脸菩萨副图指标 源码 贴图

2024-06-04 10:58:00来源:本站整理浏览:495

通达信笑脸菩萨副图指标 源码 贴图

通达信笑脸菩萨副图指标 源码 贴图

通达信笑脸菩萨副图指标 源码 贴图

ZX买入:=40;
DQHL1:=10;
ZX卖出:=80;
VAR1:=EMA(WINNER((LOW+HIGH)/2), 10)*100;
VAR2:=EMA(WINNER(CLOSE), 21)*100;
VAR3:=EMA(WINNER(CLOSE), 34)*100;
VAR4:=MA(WINNER(CLOSE), 1)*100;
VAR5:=VAR1>80 AND VAR2>80 AND VAR3>80;
VAR6:=CROSS(VAR1, VAR4);
VAR7:=VAR5 AND VAR6;
VAR8:=CROSS(90, VAR4);
VAR9:=VAR1>80;
VAR10:=VAR8 AND VAR9;
VAR11:=VAR1>80 AND VAR2>80;
VAR12:=CROSS(90, VAR4);
VAR13:=VAR11 AND VAR12;
VAR14:=(CLOSE-LLV(LOW, 100))/(HHV(HIGH, 100)-LLV(LOW, 100))*200;
VAR15:=SMA(VAR14, 3, 1);
VAR16:=SMA(VAR15, 3, 1);
VAR17:=3*VAR15-2*VAR16;
VAR18:=LLV(LOW, 5);
VAR19:=HHV(HIGH, 5);
VAR20:=EMA((CLOSE-VAR18)/(VAR19-VAR18)*100, 4)*2;
VAR21:=EMA(0.667*REF(VAR20, 1)+0.333*VAR20, 2);
VAR22:=3*VAR20-2*VAR21;
VAR23:=POW(MA(CLOSE, 5), 2)+MA(CLOSE, 5);
VAR24:=POW(MA(LOW, 5), 2)+MA(LOW, 5);
VAR25:=POW(MA(HIGH, 5), 2)+MA(HIGH, 5);
VAR26:=(VAR23-LLV(VAR24, 64))/(HHV(VAR25, 64)-LLV(VAR24, 64))*150+65-10;
VAR27:=SMA(VAR26, 3, 1)*1.5-100;
VAR28:=SMA(VAR27, 3, 1);
VAR29:=3*VAR27-2*VAR28;
VAR30:=(HIGH+LOW+CLOSE*2)/4;
VAR31:=EMA(VAR30, 13);
VAR32:=STD(VAR30, 13);
VAR33:=(VAR30-VAR31)*100/VAR32;
VAR34:=EMA(VAR33, 5);
VAR35:=EMA(VAR34, 13);
VAR36:=EMA(VAR34, 13)+200-100;
VAR37:=EMA(VAR36, 10);
VAR38:=3*VAR36-2*VAR37;
VAR39:=VAR15+VAR20+VAR27+VAR36;
VAR40:=VAR16+VAR21+VAR28+VAR37;
VAR41:=VAR17+VAR22+VAR29+VAR38;
VAR42:=(HIGH+LOW+CLOSE)/3;
VAR43:=AMOUNT/VOL/100;
VAR44:=SUM(AMOUNT, 5)/SUM(VOL, 5)/100;
VAR45:=(VAR42-MA(VAR42, 34))/(0.015*AVEDEV(VAR42, 34));
VAR46:=DMA(AMOUNT/VOL/100, VOL/CAPITAL);
VAR47:=(HIGH+LOW+CLOSE+VAR42)/4;
VAR48:=EMA(VAR47, 24);
VAR49:=STD(VAR47, 24);
VAR50:=(VAR47-VAR48)/VAR49*100;
VAR51:=(VAR42-MA(VAR42, 24))/(0.015*AVEDEV(VAR42, 24));
VAR52:=EMA(VAR50, 5);{公式网WWW.GPXIAZAI.COM}
VAR53:=(VAR43-MA(VAR43, 21))/(0.015*AVEDEV(VAR43, 21));
VAR54:=(VAR44-MA(VAR44, 90))/(0.015*AVEDEV(VAR44, 90));
VAR55:=((VAR54+VAR53+VAR52+VAR51+VAR45)/5+165)/4;
VAR56:=(EMA(EMA(EMA(VAR55, 15), 10), 5)-25)*2+VAR46;
VAR57:=(VAR39+VAR40+VAR41*30)/32/5-15;
VAR58:=EMA(VAR57, 13);
VAR59:=(VAR55+VAR57)/2/1.100;
DX:VAR59, COLORMAGENTA;
ZX:=(VAR56+VAR58)/2;
ZX-0, COLORSTICK;
VAR60:=EMA(EMA(EMA(CLOSE, 13), 13), 13);
VAR61:=((VAR60-REF(VAR60, 1))/REF(VAR60, 1)*100+0.450)*50;
VAR62:=MA(VAR61, 21);
VAR63:=((HHV(HIGH, 15)-CLOSE)/(HHV(HIGH, 15)-LLV(LOW, 15))*(-1)+0.960)*106;
VAR64:=((HHV(HIGH, 100)-CLOSE)/(HHV(HIGH, 100)-LLV(LOW, 100))*(-1)+0.960)*106;
VAR65:=(HIGH+LOW+CLOSE)/3;
VAR66:=((VAR65-MA(VAR65, 14))/(0.015*AVEDEV(VAR65, 14))+200)/4;
VAR67:=(HIGH+LOW+CLOSE*2)/4;
VAR68:=EMA(VAR67, 13);
VAR69:=STD(VAR67, 13);
VAR70:=(VAR67-VAR68)*100/VAR69;
VAR71:=EMA(VAR70, 5);
VAR72:=EMA(VAR71, 13);
VAR73:=(EMA(VAR71, 13)+100)/2-5;
VAR74:=EMA(VAR73, 10);
VAR75:=EMA(VOL/CAPITAL, 21)*13;
VAR76:=(92-100/(1+VAR75))*2.380;
VAR77:=REF(CLOSE, 1);
VAR78:=WINNER(CLOSE)*100;
VAR79:=WINNER(REF(CLOSE, 1))*100;
VAR80:=REF(INDEXC, 1);
VAR81:=(CLOSE-VAR77)/VAR77;
VAR82:=(INDEXC-VAR80)/VAR80;
VAR83:=VAR81-VAR82;
VAR84:=SMA(MAX(CLOSE-VAR77, 0), 4, 1)/SMA(ABS(CLOSE-VAR77), 4, 1)*100;
VAR85:=SMA(MAX(CLOSE-VAR77, 0), 8, 1)/SMA(ABS(CLOSE-VAR77), 8, 1)*100;
VAR86:=SMA(MAX(CLOSE-VAR77, 0), 12, 1)/SMA(ABS(CLOSE-VAR77), 12, 1)*100;
VAR87:=SMA(MAX(CLOSE-VAR77, 0)*(1+VOL/CAPITAL), 12, 1)/SMA(ABS(CLOSE-VAR77)*(1+VOL/CAPITAL), 12, 1)*100;
VAR88:=SMA(MAX(VAR78-VAR79, 0), 12, 1)/SMA(ABS(VAR78-VAR79), 12, 1)*100;
VAR89:=SMA(MAX(VAR83, 0), 12, 1)/SMA(ABS(VAR83), 12, 1)*100;
VAR90:=(VAR84+VAR85+VAR86)/3;
VAR91:=(VAR87+VAR88+VAR89+VAR90)/4;
VAR92:=(VAR91-31)*2.300;
VAR93:=(EMA(EMA(EMA(EMA(VAR92, 4), 3), 2), 1)-10)*1.430;
VAR94:=(HIGH+LOW+CLOSE*2)/4;
VAR95:=EMA(VAR94, 13);
VAR96:=STD(VAR94, 13);
VAR97:=(VAR94-VAR95)*100/VAR96;
VAR98:=EMA(VAR97, 5);
VAR99:=EMA(VAR98, 13);
VAR100:=(EMA(VAR99, 13)+100)/2-5;
VAR101:=EMA(VAR100, 10);
VAR102:=3*VAR100-2*VAR101;
VAR103:=(CLOSE-LLV(LOW, 90))/(HHV(HIGH, 90)-LLV(LOW, 90))*100;
VAR104:=SMA(VAR103, 7, 1);
VAR105:=SMA(VAR104, 10, 1);
VAR106:=3*VAR104-2*VAR105;
VAR107:=POW(MA(CLOSE, 5), 2)+MA(CLOSE, 5);
VAR108:=POW(MA(LOW, 5), 2)+MA(LOW, 5);
VAR109:=POW(MA(HIGH, 5), 2)+MA(HIGH, 5);
VAR110:=(VAR107-LLV(VAR108, 100))/(HHV(VAR109, 100)-LLV(VAR108, 100))*100-15;
VAR111:=SMA(VAR110, 21, 1)*1.5;
VAR112:=SMA(VAR111, 3, 1);
VAR113:=3*VAR111-2*VAR112;
VAR114:=POW(MA(CLOSE, 5), 2)+MA(CLOSE, 5);
VAR115:=POW(MA(LOW, 5), 2)+MA(LOW, 5);
VAR116:=POW(MA(HIGH, 5), 2)+MA(HIGH, 5);
VAR117:=(VAR114-LLV(VAR115, 64))/(HHV(VAR116, 64)-LLV(VAR115, 64))*100;
VAR118:=SMA(VAR117, 2, 1);
VAR119:=SMA(VAR118, 2, 1);
VAR120:=3*VAR118-2*VAR119;
VAR121:=EMA(VOL/CAPITAL, 21)*100;
VAR122:=(100/(1+VAR121)*(-1)+92)*1.570;
VAR123:=DMA(AMOUNT/VOL/100, VOL/CAPITAL);
VAR124:=(HIGH+LOW+CLOSE)/3;
VAR125:=((VAR124-MA(VAR124, 5))/(0.015*AVEDEV(VAR124, 5))+VAR123+140)/4;
VAR126:=EMA(EMA(EMA(CLOSE, 100), 100), 100);
VAR127:=((VAR126-REF(VAR126, 1))/REF(VAR126, 1)*100+0.280)*179;
VAR128:=EMA(VAR127, 20);
VAR129:=(VAR106+VAR113)/2;
VAR130:=(VAR118+VAR119+VAR120+VAR100+VAR104+VAR111+VAR122+VAR101+VAR105+VAR112+VAR102+VAR106+VAR113+VAR125+EMA(VAR66, 5)*5)/20;
VAR131:=(VAR100+VAR104+VAR111+VAR122+VAR129+VAR127+VAR128)/7;
VAR132:=(VAR101+VAR105+VAR112+VAR122+VAR129+VAR127+VAR128)/7;
VAR133:=(VAR131+VAR132)/2*1.220;
VAR134:=(EMA((VAR129+VAR133+EMA(VAR130, 5))/3, 89)-12)*1.720;
VAR135:=(VAR133+VAR134)/2;
VAR136:=WINNER(CLOSE)*100;
VAR137:=(EMA(CLOSE, 12)-EMA(CLOSE, 26))*10;
VAR138:=EMA(VAR137, 12);
VAR139:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR140:=(20*VAR136+19*REF(VAR136, 1)+18*REF(VAR136, 2)+17*REF(VAR136, 3)+16*REF(VAR136, 4)+15*REF(VAR136, 5)+14*REF(VAR136, 6)+13*REF(VAR136, 7)+12*REF(VAR136, 8)+11*REF(VAR136, 9)+10*REF(VAR136, 10)+9*REF(VAR136, 11)+8*REF(VAR136, 12)+7*REF(VAR136, 13)+6*REF(VAR136, 14)+5*REF(VAR136, 15)+4*REF(VAR136, 16)+3*REF(VAR136, 17)+2*REF(VAR136, 18)+REF(VAR136, 20))/210;
VAR141:=MA(VAR140, 10);
VAR142:=ZX< ZX买入;
VAR143:=VAR137-VAR138>=0;
QQ3:=CROSS(VAR137, VAR138);
JC:INTPART(QQ3),COLORGREEN;
VAR144:=COUNT(CROSS(DX, ZX), 20)>=1;
VAR145:=VAR142 AND QQ3 AND VAR144;
VAR146:=COUNT((CROSS(DX, 0) AND ZX< 10)>0, 5)>=1;
VAR147:=VAR142 AND QQ3 AND VAR146;
卖点看黄箭:STICKLINE((VAR1< DQHL1 AND CROSS(VAR137, VAR138))>0, 0, 10, 30/3, 1),COLORFFDDDD;
买看海底声纳:STICKLINE((CROSS(ZX, DX) AND ZX>ZX卖出)>0, 0, 50, 10/3, 0), COLORYELLOW;
金针探底:STICKLINE(CROSS(100, DX)>0, 0, 100, 20/5, 0), COLORYELLOW;
再看笑脸菩萨:STICKLINE(CROSS(VAR141, VAR140)>0 AND ZX>10, 120, 100, 1/3, 0), COLORGREEN;
100, POINTDOT;{公式网WWW.GPXIAZAI.COM}
STICKLINE(VAR1>13 AND VAR1< 80, 3, 0, 10/3, 1), COLOR009933;
STICKLINE(VAR1< 13, (-30), (-25), 10/3, 1), COLORYELLOW;
STICKLINE(VAR1>80, 5, 0, 10/3, 1), COLORBLUE;
STICKLINE(VAR7>0, 0, 100, 10/3, 0), COLORYELLOW;
STICKLINE(VAR10>0, 0, 100, 10/3, 0), COLORYELLOW;
STICKLINE(VAR13>0, 0, 100, 10/3, 0), COLORYELLOW;
DRAWICON(VAR145>0, 0, 1);


 

 

股票公式栏目导航

本类热门

相关公式