通达信擒龙术副图指标 源码 贴图

2024-07-04 10:59:00来源:本站整理浏览:511

通达信擒龙术副图指标 源码 贴图

通达信擒龙术副图指标 源码 贴图

通达信擒龙术副图指标 源码 贴图

VAR1:=EMA(CLOSE,2);
VAR2:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
VAR3:=MA((-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19);
VAR4:=(-100)*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
VAR5:=EMA((-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4);
DRAWGBK(OPEN>0,RGB(33,47,58),RGB(0,0,0),0,574,0);
DRAWBAND(VAR5+100,RGB(150,50,50),VAR3+100,RGB(0,0,255));
短线:VAR4+100,NODRAW,COLORLIBLUE;
中线:VAR5+100,COLORYELLOW,LINETHICK2;
长线:VAR3+100,COLORGREEN;
VAR6:=50+(中线-长线);{公式网 WWW.GPXIAZAI.COM}
VAR7:=(CROSS(中线,短线) OR CROSS(REF(中线,1),REF(短线,1)));
VAR8:=中线<REF(中线,1) AND REF(中线,1)>80;
VAR9:=(REF(短线,1)>95 OR REF(短线,2)>95) AND 长线>60;
VAR10:=VAR8 AND VAR9 AND 短线<83.5 AND 短线<中线 AND 短线<长线+4;
VAR11:=长线<12 AND 中线<8 AND 短线<7.2 AND REF(短线,1)<5;
VAR12:=中线>REF(中线,1) AND 短线>REF(短线,1);
VAR13:=(长线<8 AND 中线<7 AND 短线<15 AND 短线>REF(短线,1));
VAR14:=长线<15 AND REF(长线,1)<15 AND 中线<18 AND 短线>REF(短线,1);
VAR28:=VAR14 AND CROSS(短线,长线) AND 短线>中线;
VAR29:=(REF(短线,1)<5 OR REF(短线,2)<5);
STICKLINE(VAR6>50,VAR6,50,0.0001,0),COLORRED;
STICKLINE(VAR6<=50,VAR6,50,0.0001,0),COLORGREEN;
龙海:100-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),NODRAW,COLORWHITE;
STICKLINE(龙海>=100,110,100,3,1),COLORYELLOW;
STICKLINE(龙海<=0,0,(-10),3,1),COLORRED;
见顶:长线>85 OR REF(长线,1)>85 AND VAR7 AND CROSS(长线,短线),NODRAW,COLORLIGREEN;
STICKLINE(见顶 OR VAR10,99,103,9,0),COLORRED;
底部:VAR11 AND VAR12 OR VAR13 OR (长线<10 AND 中线<7 AND 短线<1),NODRAW,COLORYELLOW;
STICKLINE(底部,(-4),0,22,0),COLORGREEN;
底叉:VAR28 AND VAR29 AND (中线>=长线 OR REF(短线,1)<1),NODRAW,COLORLIRED;
STICKLINE(底叉,0,5,11,0),COLORRED;
底买:CROSS(中线,长线) AND VAR1>=VAR2 AND 中线<20,NODRAW,COLORYELLOW;
DRAWICON(底叉,5,23),COLORYELLOW;
DRAWTEXT(CROSS(中线,长线) AND VAR1>=VAR2 AND 中线<20,长线-1.15,'主现'),COLORYELLOW;
DRAWICON(CROSS(中线,长线) AND VAR1>=VAR2,长线,1);
DRAWICON(CROSS(中线,长线) AND VAR1>=VAR2 AND 中线<20,长线,5);
DRAWICON(CROSS(长线,中线),长线,2);
DRAWICON(CROSS(长线,中线) AND 中线>80,长线,6);
DRAWTEXT(CROSS(长线,中线) AND 中线>80,长线+1.15,'庄现'),COLORGREEN;
80,DOTLINE,COLOR996699;
20,DOTLINE,COLORGREEN;


 

 

股票公式栏目导航

本类热门

相关公式