通达信2018 破军一号副图指标(源码 附图)

2017-06-19 10:21:00来源:本站整理浏览:394

{破军1号}

{参数 P:60,Q:30}

A1:=AMOUNT/VOL/100;

A2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;

A3:=SUM(AMOUNT,40)/A1/100;

A4:=SUM(AMOUNT,80)/A1/100;

B1:=DMA(A2,VOL/A3);

B2:=DMA(A2,VOL/A4);

B3:=(CLOSE-B1)/B1*100;

B4:=(CLOSE-B2)/B2*100;

控盘:1,COLORYELLOW,LINETHICK1;

极限:5,,COLORFF6600;

风险:-1,COLORGREEN,LINETHICK2;

低点:-4,COLORCCFF33;

现价:C,NODRAW;

DRAWTEXT(ISLASTBAR AND C,4.3,' ▲买 出现立刻关注'),COLORFF00FF;

DRAWTEXT(ISLASTBAR AND C,3.2,' 黑马 出现必持待涨'),COLORDB7093;

DRAWTEXT(ISLASTBAR AND C,2.1,' 牛牛 出现后市必高'),COLORYELLOW;

DRAWTEXT(ISLASTBAR AND C,1.0,' ▼卖 出现准备卖出'),COLORGREEN;

DRAWTEXT(ISLASTBAR AND C,-0.1,' 短红柱蓄势待发'),COLORRED;

DRAWTEXT(ISLASTBAR AND C,-1.2,' 洋红柱主力做多'),COLORMAGENTA;

DRAWTEXT(ISLASTBAR AND C,-2.3,' 遵守原则是上策'),COLORYELLOW;

DRAWTEXT(ISLASTBAR AND C,-3.4,' 冷静操盘获利多'),COLORYELLOW;

STICKLINE(FILTER(C,60)>0,极限,低点,0.5,0),COLORRED;

STICKLINE(B4>0,0,B4,1,0),COLORYELLOW;

STICKLINE(B3>0,0,B3,1,0),COLORRED;

STICKLINE(B3<=0,0,B3,1,0),COLORGREEN;

H1:=MAX(DYNAINFO(3),DYNAINFO(5));

L1:=MIN(DYNAINFO(3),DYNAINFO(6));

P1:=H1-L1;

阻力:=L1+P1*7/8;

支撑:=L1+P1*0.5/8;

现价1:=CLOSE;

DRAWTEXT(LONGCROSS(支撑,现价1,2),-1,'▲买'),COLORFF00FF;{吸}

DRAWTEXT(LONGCROSS(现价1,阻力,2),1,'▼卖'),COLORGREEN;{抛};

VAR1:=EMA(EMA(CLOSE,13),13);

控盘1:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;

{分时价格原码}

JJ:=DYNAINFO(11);

{波段买卖原码}

P:=55;S:=8;M1:=3;

财:=(EMA(CLOSE,S)-EMA(CLOSE,P))*10,COLORRED,LINETHICK2;

神:=EMA(财,M1),COLORGREEN,LINETHICK1;

{股价与均线偏离买卖条件}

BTJ11:=(C-JJ)/JJ<-0.03;

BTJ1:=(C-JJ)/JJ<-0.005;

BTJ2:=控盘1>REF(控盘1,1) AND 控盘1<-0.2;

{波段买卖条件}

BTJ3:=CROSS(财,神) AND 财<-0.3;

{以下为信号};

BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,13);

BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);

马:= BTJ11 AND BTJ2 AND BTJ3;

黑马:FILTER(马,2),COLORDB7093,LINETHICK3;

DRAWTEXT(BTJ811,黑马*1.5,'黑马'),COLORDB7093;

牛:=(C-JJ)/JJ<-0.03;

DRAWTEXT(牛,4,'牛')COLORYELLOW;

VAR2:=LLV(LOW,33);

VAR3:=HHV(HIGH,21);

VAR4:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*100,10)*-1+100;

安全线:(100-EMA(0.191*REF(VAR4,1)+0.809*VAR4,1))/20,LINETHICK2,COLORBLUE;

风险值:(100-EMA(0.191*REF(VAR4,1)+0.809*VAR4,1))/20,CIRCLEDOT,LINETHICK2,COLORRED;

BGTYU:=IF(DATE<=1150530,1,0);

GHYJKU:=BETWEEN((CLOSE*BGTYU)/(SUM(AMOUNT,BARSCOUNT((CLOSE*BGTYU)))/SUM(VOL*100,BARSCOUNT((CLOSE*BGTYU)))),1.05,0.95);

VBNH:=IF(GHYJKU=0,MA((CLOSE*BGTYU),BARSCOUNT((CLOSE*BGTYU))),(SUM(AMOUNT,BARSCOUNT((CLOSE*BGTYU)))/SUM(VOL*100,BARSCOUNT((CLOSE*BGTYU)))));

STICKLINE(EMA(C,10)>EMA(C,60) ,-3,-2.5,2.0,0),COLORRED;

STICKLINE(EMA(C,10)<EMA(C,60) ,-3,-3.5,2.0,0),COLORGREEN;

STICKLINE(EMA((CLOSE/VBNH),120)>1.003 ,-3,-2,2.0,0),COLORMAGENTA;

DRAWTEXT(CROSS(EMA((CLOSE/VBNH),120),1.004),-3,'强劲主力'),COLORYELLOW;

DRAWICON(CROSS(EMA((CLOSE/VBNH),20),1.003),-3.5,27);

DRAWICON(CROSS(EMA((CLOSE/VBNH),20),1.003),-3.5,27);

DRAWTEXT(CROSS(EMA((CLOSE/VBNH),20),EMA((CLOSE/VBNH),60)),-3.5,'看涨'),COLORBLUE;

DRAWTEXT(CROSS(EMA((CLOSE/VBNH),20),EMA((CLOSE/VBNH),60)),安全线,'大资金活动'),COLOR38B0DE;

 


 

通达信2018 破军一号副图指标(源码 附图)

股票公式栏目导航

本类热门

相关公式